Error connecting to authd on host

We have Virtual Center 2.5 installed on a server. When trying to connect to the console for a virtual machine through the VMWare Infrastructure Client (From the Vcenter server), we get the error: Error connecting to authd on host. We get the same error when going through a webbrowser to the Virtual Center server, or directly to the ESX hosts. However it works just fine if we connect from another workstation to the Virtual Center server.  

I've researched and tried about everything to fix this but without luck. The VCenter server and the workstation on which it works fine are running the same version of VIC.

Your help would be very much appreciated.
LVL 3
gimosubyAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

coolsport00Commented:
Since you didn't provide what you tried, I'll post these links to see if they help:
http://communities.vmware.com/message/733306;jsessionid=1488313EC3F438936D6480CFE4336999
http://www.experts-exchange.com/Software/VMWare/Q_24914351.html
http://communities.vmware.com/message/1325096;jsessionid=562198590FD473BEF79394C24299DE74

Another thing I would try, if you're able, is to reboot your Virt Ctr server.

Also...just so I'm reading your post correct: are you saying that if you use the client on your workstation, it's fine, but if you use the client on the virt ctr server, you get that error?

Regards,
~coolsport00
0
gimosubyAuthor Commented:
Yes, you're reading that correct. It doesn't work using the client on the virt ctr server, whether I connect to localhost, or remote ESX servers through client or webbrowser. When I try it from my own workstation it works fine whether I connect to the virt ctr server or straight to the ESX server. the VCI clients are the same version on the virt ctr server and my workstation.

What I've tried.
- Uninstall and re-install virt ctr server and VCI.
- Rebooting

There is no firewall between the virt ctr server and my ESX server, everything was working fine until recently. I can't think of any big changes that occurred that could have caused this...
0
coolsport00Commented:
A couple other things to try...have you (or are you able to) rebooted your ESX servers? Also, what if you typed in the IP or hostname of your VC server instead of using "localhost"?

~coolsport00
0
Acronis Data Cloud 7.8 Enhances Cyber Protection

A closer look at five essential enhancements that benefit end-users and help MSPs take their cloud data protection business further.

gimosubyAuthor Commented:
Thanks for your suggestions. I've tried connecting to the IP and hostname of the vcenter server using the VIC on the vcenter server but no luck. I've also tried to connect straight to the ESX servers which didn't work either.
Rebooting the ESX server didn't make a difference and since I'm able to connect just fine to it from another workstation I don't think it has anything to do with my ESX servers.
0
coolsport00Commented:
Hmm...since access to 'authd' requires port 902 to be open, the only other thing I can suggest is to see if the Windows Firewall is enabled and, if it is (and you require it to be) to add port 902 as an exception.

Regards,
~coolsport00
0
gimosubyAuthor Commented:
Windows Firewall is not enabled so that can't be the problem...
0
coolsport00Commented:
I've run out of searches and possilbe solutions :) This may be something you'll need to contact VMware Support for. Sorry I couldn't get this resolved for you :(

~coolsport00
0
gimosubyAuthor Commented:
Okay, I'll post an update once I've got it fixed. I knew this was going to be a hard one as I did all my homework before posting this question. Thanks for your efforts.
0
coolsport00Commented:
Yes...be curious to know the answer myself :)
0
gimosubyAuthor Commented:
Okay, here we go...

I removed VMware Virtual Center and Virtual Infrastructure Client (VMware vCenter Server 2.5 Update 6) from the server, then downloaded the VIC from the ESX server (VMware ESX 3.5 Update 4) with my webbrowser. I installed that VIC and it worked fine, then I uninstalled it and downloaded and installed the VIC from VMware vCenter Server 2.5 Update 5 and that worked fine, so then I installed VMware vCenter Server 2.5 Update 6 and I got the error again. So now I'm running VMware vCenter Server 2.5 Update 6 with the VIC of VMware vCenter Server 2.5 Update 5 and it works. From the workstation I'm still able to connect just fine using the VIC from VMware vCenter Server 2.5 Update 6.

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.