Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

Troubleshooting
Research
Professional Opinions
Ask a Question
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

troubleshooting Question

Changing "display name" does not alter whats shown when searching..

Avatar of Ben Hart
Ben HartFlag for United States of America asked on
Active Directory
6 Comments1 Solution7244 ViewsLast Modified:
Ok so a co-worker, (whose a programmer but I guess I wont hold that against him ;p)

He created a domain user account by using the ADU&C MMC snapin under his non-admin domain credentials.  The user called needing their last name changed, so the co-worker went back in and altered the Last Name and display name fields, hit apply then OK.  However when you refresh the OU contents it still displays the old last name.

Then he tells me, I VNC into a DC and double check and sure enough the display name listed after performing a search shows the old last name, but when you view the properties on the account it shows the correct contents.

I have tried altering the CN value under the Attribute Editor tab but when I hit apply I'm given an error:

Operation Failed. Error code: 0x20b1
The attribute cannot be modified because it is owned by the system.

000020B1: UpdErr: DSID-030F0AE8, problem 6004
(CANT_ON_RDN),data 0


So this prompted me to check to see who the Owner is of this account under teh Security tab.. sure enough it's the co-worker.  So I change it to the Domain Admin account like the others are but Im given the same error when I try to alter that field again and I cannot change from the account properties box either.


What's going on?
ASKER CERTIFIED SOLUTION
Avatar of Mike Thomas
Commented:
This problem has been solved!
Unlock 1 Answer and 6 Comments.
See Answers