2008 R2 remote desktop services not working

Dear experts,
I have a stand alone 2008 server with no AD, this server is running our financial database using SQL and Apache server, I have activated remote desktop services to allow me to connect to it from windows 7 remote desktop cleint
my problem is I can connect to me 2003 servers and not the 2008 one ?????
what could be the problem?  is it true that AD needs to be installed inorder to use RDS?
sameh_mhumaidAsked:
Who is Participating?
 
jermorseConnect With a Mentor Commented:
I think it sounds like you are blocked on port 3389 by a firewall. If telnet failed then I don't think RDP would function. Unless you have manually selected a non-default RDP port.

Check for a firewall on either the Windows OS or perhaps a router or firewall device between the two machines.
0
 
ConchCrawlCommented:
I could give you all the things to check but suffice it to say this link may be shorter and it has pictures :-) hope this helps.
http://www.techotopia.com/index.php/Configuring_Windows_Server_2008_Remote_Desktop_Administration
If it doesn't please specify in more detail what error(s) you are getting from the client on W7 when you try to connect.
0
 
jermorseCommented:
Be sure that the Windows 2008 Sever Firewall isn't blocking your RDP connection. Usually RDP is on port TCP 3389
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
sameh_mhumaidAuthor Commented:
Tried to telnet port 3389 and said connection failed
0
 
sameh_mhumaidAuthor Commented:
one more thing, Terminal services are no longer avilable in 2008 server?
0
 
ConchCrawlCommented:
That's because in R2 they've changed the name to Remote Desktop Services and no longer Terminal Services, go figure :-).
0
 
ConchCrawlCommented:
Have you done the following:
enabled remote desktop administration on the remote server?
Open the Control Panel from the Start menu and selecting the System icon. In the Task section in the top left hand corner of the System page select Remote settings to display the System Properties. click on the Remote tab and under remote desktop check the middle box allow connections from computers running any version of remote desktop. By default all memebers of the administration group are allowed to connect remotely.
If the Windows Firewall is active, the act of enabling Remote Desktop administration also results in the creation of a firewall exception allowing Remote Desktop Protocol (RDP) traffic to pass through on TCP port 3389.  
Check this out, I hope this helps.
0
 
sameh_mhumaidAuthor Commented:
Is it necessary to install AD? I don’t need it on this server but I have read that it is a requirement?
0
 
sameh_mhumaidAuthor Commented:
my previous question was related to installing and configuring remote desktop and not in general
thanks
0
 
ConchCrawlCommented:
No, you do not need AD on the server to install RDS for administrative purposes.
I'm assuming you are in a domain and have AD installed elsewhere.
But no, I have never had/seen a requirement for and individual workstation or server to have AD installed on it.
Did you check out my previous comments to see it those things have been done?
0
 
sameh_mhumaidAuthor Commented:
i will when i go to office
Thanks
0
 
sameh_mhumaidAuthor Commented:
I have other 2003 servers in the same network environment and all accept remote terminal services!
if they are using the same ports then i dont think it is a firewall probelm
Just thinking loud ...
0
 
sameh_mhumaidAuthor Commented:
Thank you
0
All Courses

From novice to tech pro — start learning today.