• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 583
  • Last Modified:

Sharepoint page does not render correctly with anonymous user

Hi,

My site only renders correctly if I'm logged in..
I have a Root site and a subsite. I have style sheets in both the root and the subsite.

The anonymous user can access the entire site but when the page renders is not applying the style sheet located in the root site.

I do not need my anonymous users to navigate to the actual style sheet list. I just need the page to be able to apply all the styles in the style sheet library from the root site.

Any ideas? I have done everything I've found on internet
1. Allowing anonymous access to the entire site
2. Recreated the site with anonymous access from the beginning
3. Enable view access to the root style sheet library
4. Enable and disable ViewFormPagesLockDown.. although this does not seem to apply in my scenario...

I've been trying to fix this issue for  hours..
0
evaluna76
Asked:
evaluna76
1 Solution
 
arunjeyachandranCommented:
Go to property of virtual directory and set the access permission for your Main folders and sub folders.
Now it ll work fine.
0
 
webmaisterCommented:
You can also put your style sheets in the layouts directory under the 12 hive.  The layouts/templates directory on the server becomes a virtual _layouts dir in every URL for every SharePoint site.  Another thing you can do is create a separate document library at the root site to store the files needed for Anonymous users to view things correctly and then just allow Anonymous users read only access to this Doc library by permissioning it separately.
0

Featured Post

Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now