Quicksilver on mac sometimes thinks a file is a url

I use Quicksilver on OS X, but have not gotten used to it very much. One thing that really irks me is that sometimes when I type something in my file system, which could be either a folder or a filename, QS insists that it wants to look for a URL.

It finds the full path, but the icon is the "world" and the action on the right is "open URL". Of course this does not work and nothing happens.

What controls this bizarre behavior and how do I correct it?
jasimon9Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Pete83Commented:
Would you be able to post a screenshot of an example? I use Quicksilver myself and haven't come across this type of behaviour when typing in file names.
0
jasimon9Author Commented:
I have attached a screen shot. I have typed in PIM and the first item is ~/Music/Pimsleur. While seemingly this should be a file system path, as you can see it is consider to be a URL. When clicking on it "nothing happens", presumably because that is not a correctly-formed URL.

Screen-shot-2010-03-23-at-1.17.1.png
0
marookCommented:
Well, I use QS a lot and this naver happens to me.

Could it be that the Action for Open URL is set higher in preference than the other you like to use?

QuickSilver: Preferences: Actions
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

jasimon9Author Commented:
My QS seems to be broken. When trying to load the Preferences, it just comes up as a blank window.

I suppose I should uninstall / reinstall. But any other suggestions before doing that are welcome.

While QS is undoubtedly powerful, I find its interface to be quirky, very un-intuitive. So I have not been able to tap into the power yet.
0
Pete83Commented:
Out of curiosity which version of QS are you using? The latest version is ß58 and can be found here: http://github.com/tiennou/blacktree-alchemy/downloads

Try installing that if you're on an earlier version and see if that fixes your issue.
0
jasimon9Author Commented:
ß56 (3824)

I usually keep current. However, a blank Preference panel would not be a "feature" of an earlier version. Probably the version I have is simply corrupted. I agree that installing the latest version is a good idea, simply because re-installing is a good idea, and even re-installing the current version would probably fix it.

But why not have the latest and greatest?
0
jasimon9Author Commented:
I installed ß58 (3841).

Preferences is now working. But I do not see Preferences > Actions. Could you please be more specific?
0
Pete83Commented:
Actions should be in the left hand panel of preferences.
Screen-shot-2010-03-25-at-17.37..png
0
jasimon9Author Commented:
This is weird. The preference panel when I got it working again after the reinstall looked nothing like yours. It had no entries below the line, in any of the 4 categories.

However, when I open it now, it does.

In checking further, for some reason clicking on Preferences brought up only the Catalog view, not the Preferences view. But all the views are working now.

I see that "Open URL" is rank 14, whereas Open File is 3. I don't know if this is different during when I was having problems, but both of those settings seem reasonable at this point. I should say that I did solve the problem of the file path not showing up by adding  /Music to the catalog. So after doing that, at least the one I wanted showed up, whereas before, only the URL showed up (the screen shot is from after I made this fix).

Something that still puzzles me -- if you look at my first screen shot, it shows ~/Music/Pimsleur as the first item and as a URL. Why would a file path even be considered a URL? And why would it be first?

Lastly, is there any good documentation for QS? I have viewed on many of the resources which seem to be scattered all over the place, with FAQs, Tips, original-one-and-only guides, etc, etc. But none of them are very helpful imho. Any really useful ones out there?
0
Pete83Commented:
To be honest I'm not sure what caused your initial issue other than it's use of the tilde(~) but for documentation one of the best places to visit is the Google Group for it here: http://groups.google.com/group/blacktree-quicksilver good useful guides and how-tos.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jasimon9Author Commented:
Ironically, I think I contributed most to the solution original question by adding to the catalog. While this solved my problem, the core of the original question about why the URL item was present has not been solved and is still a mystery.

I am awarding points because of the answers to the followup questions, re working with the Preferences panel and for the suggestion on documentation.

On that web page there was a link to  the Quicksilver User Manual by Howard Melman, which I had used when I first started with QS a ways back, but lost track of.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Mac OS X

From novice to tech pro — start learning today.