RemoteApp Disconnected - "remote computer could not be found"Question

Have just set up a Server 2008 R2 machine with Remote Desktop Services.  It's all running on the one server, just for a couple of applications, which works fine locally and when using Remote Desktop Web Access on the local network.

However, when accessing it over the Internet, you can log on to RD Web Access fine, but when running the RemoteApp you get the message:

RemoteApp Disconnected
The remote computer could not be found. Please contact your helpdesk about this error.
I have registered the external name in dns and allowed it thru my firewall.
I have tried different setting on terminal server settings within remote apps manager. I tried using external ip address, external dns name. I am not using a remote gateway, the terminal servers are not in a farm.  
jim3725Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NJComputerNetworksCommented:
For #2, most likely you didn't configure your TS RemoteApp programs correctly, so clients in internet still trying to access TS as if it would appear in local network. You can check it really quick (there is easier way to do that, but I will list longer way as it contains some other things you might find useful):
- Login to your TS as admin
- Open RemoteApp Manager MMC
- Right click on any RemoteApp programs from the list, and select "create .rdp" file, follow the wizard
- Go to the folder where you created your RDP with Windows Exporer
- Right click on the file created, choose "Open With" and select "Notepad" (make sure the "Always use the selected program" is unchecked).
- Make sure that "gatewayhostname:s:" with the correct external name of your TS Gateway (without "https://") is in the file.
If it's there, then I need more info to help you troubleshoot (what's exactly the error message, what user sees on the TSWA portal, what is the content of the RDP file, can the user connect from internet with RDP file bypassing TSWA). If it's not, this is what I thought, and you have to configure it:
- In RemoteApp Manager, in Actions panel, go to "TS Gateway Settings" and configure this section appropriately.

from here:  http://social.technet.microsoft.com/forums/en-US/winserverTS/thread/0f843354-15e0-41db-bf60-79eb22e6c632
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jim3725Author Commented:
I just installed gateway services roles on the server, and created the necessary groups for the cap and rap policy. The gateway external host name is configured to match the external A record.
When I tried to connect from internet It brings up my published apps fine.
When I click on my intranet link, then I get remote computer name is my local terminal name (ts1)
The  gateway server name is the external name which I have registered A record along with my internal dns has the same public dns name. (remote.pvhhealthcare.org) When i click connect then I get prompted for authenication 1.(ts gateway server)= remote.pvhhealthcare.org
2. remote computer)=ts1.pvh.local. I put in my username prefaced by domain/username and password.
I then get message of Remote App Disconnected.  TS rap is preventing connection to remote computer, TS gateway, Due to following reasons: 1. Don't have permissions to connect to remote computer through the TS Gateway Server.  2. The name specified in the remote computer does not match the name in the TS rap
0
jim3725Author Commented:
I referenced the url to the social net forum, which pointed me in the direction of the Firewall rules.
I also moved the certificate from personal to trusted root certificate authoriy. I had to install the cert on the client pc.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.