AdMob ad in iPhone app makes App content disappear when “done” is pressed!

Hello All,

     When I return from an adMob ad by hitting "done" the content of my app has disappeared !  All that remains is a background image I had attached directly to the main window.  Oddly I can still hear the result of my touch events from my main screen (which is now gone).  

This may be related to the issue some people have had regarding a 20 pixel move involving the toolbar...I see something to that effect as the ad starts to overlay.  I have admob in another app that is working fine, and I notice when the ad opens in that app the ad content fills the whole screen EXCEPT the top toolbar (it starts right under it).  In the new app I'm working on right now this isn't the case.  When the ad starts to open I see the tool bar vanish, then the add comes in and fills the entire screen (including the area where the tool bar was); then when I click done and the the ad goes away everything under it is gone as well.  It may be worth noting that the App I had working was 2.x and the current app is 3.x (and thus using the admob 3.0 libraries).

This is very odd and deal-breaking; I need help ASAP
The relevant part of my view hierarchy is as follows:

AppDelegate - ViewController - MainView (Ad is in here)

There are also some other Views that are children of the ViewController and a UITabbar is also a subview of the ViewController (programmatically declared, not a UITabBar Controller).

Any help you can offer would be extremely appreciate...I need to resolve this issue ASAP, release in two days!  Thanks!!
LVL 1
andrewaielloAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

pgnatyukCommented:
If you paid attention the same happens in Mail, when you press on a link. You know the iPhone OS is not a multi-process system. So that's what we have.
Please check this link:
http://developer.admob.com/wiki/IPhone

You can find an example in the end with [[UIApplication sharedApplication] openURL:url];
If you use this approach, so I'm right.
But before this paragraph you can find "SDK Integration instructions" - this code will show everything in UIWebView.

0
andrewaielloAuthor Commented:
Actually this turned out to be a bug in Admob itself, which they corrected.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
iPhone

From novice to tech pro — start learning today.