[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1030
  • Last Modified:

My Hyper-V network disconnecting seemingly at random

I have a Windows 2008 R2 server with the Hyper-V role installed.
I am running 3 virtual machines on this server connected to 2 virtual switches and one network port is used for Administration.
Occasionally one the machines will suddenly stop appearing on the network. I am unable to ping the machines and I am unable to ping a network machine from one of the virtual machines. They do not all stop working at the same time. In fact, I have two machines connected to the same virtual switch and one will stop working while the other one works just fine.
I have tried disable/enabling the adapter on the virtual machine. I have tried moving the machine to the second virtual switch to no avail. My only option is to reboot the machine.
I can find nothing in the event logs that give me any clue as to the problem.

Any ideas?
0
Hawkeye_11105
Asked:
Hawkeye_11105
  • 2
1 Solution
 
EmptyoneCommented:
Not sure if this is exactly how you experience it, but have a look at this hotfix: http://support.microsoft.com/kb/974909
0
 
Hawkeye_11105Author Commented:
Thanks for the info but I don't think this is exactly my problem as the network adapter is never shown as disabled.
I may try to install the patch anyway but I will look into the KB article a bit more
0
 
Hawkeye_11105Author Commented:
So I installed the patch over the weekend. Now I just need to wait a few days to make sure that everything works correctly
0

Featured Post

The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now