DHCP on 2008R2 getting MMC cannot initialize the snap-in

Hello,

Every time I click on Address Leases in my IPv4 Scope, I get a "MMC cannot initialize the snap-in" error.  I also noticed that there is a red X on the folder next to Address Leases.  Everything else in the MMC works fine.

Items that might be good to know:
Windows 2008 R2 Server
Only one IPv4 scope, no IPv6 scopes
Scope was on a 2003 server and I moved it to this server
I have a couple of old servers listed in Manage Authorized Servers list that are no longer around.

Thanks in advance for your help,
Mike
mikechadwickCIOAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NJComputerNetworksCommented:
Do you have a Vista or Windows 7 machine around to try to manage DHCP from... just checking to see if the MMC is messed up or something else.

You have to load this tool on the vista machine to get the DNS console http://support.microsoft.com/kb/941314

you have to load this tool on the Windows 7 machine to get the DNS console tool:  http://www.microsoft.com/downloads/details.aspx?FamilyID=7d2f6ad7-656b-4313-a005-4e344e43997d&displaylang=en
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mikechadwickCIOAuthor Commented:
Well, this is interesting...

I installed the server tools for Windows 7, then opened up the tool and added my only authorized DHCP server that was listed (thanks to your second post).  Once I selected it and added it, it brings me back to the main screen, but instead of my DHCP server being listed it is showing one of my AD servers...  I also tried to browse when selecting the DHCP server and the same thing happens.  Not sure what is going on with that.
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

NJComputerNetworksCommented:
hmm... do you think there might be a network resolution problem?  What is the name of your DC? what is the name of your DHCP server... can you ping both of them by name from the Windows 7 server?

0
mikechadwickCIOAuthor Commented:
DC is called "Active-D"
DHCP is on "Backup"

Pinging both resolves to the right IP

I also rebooted both the DHCP server and the win7 machines.
0
mikechadwickCIOAuthor Commented:
I installed the tools on a Vista machine and when I select the DHCP server, it is the one that show up.  But, when I click on the server, it says cannot find the DHCP server.

The error was: A security package specific error occurred.

I remembered that I took myself out of the Admin's group so I added myself back in but still same problem.

0
mikechadwickCIOAuthor Commented:
Update:

The error I was getting on the Windows 7 and Vista machines was because of the reverse PTR record being wrong in DNS.  Once I fixed that I was able to run the DHCP MMC just fine.

When i try to administer the DHCP server from a remote machine, I am getting the same error on those machines as I am with the server.  I can click on everything else, but when I click on Address Leases I get "MMC cannot initialize the snap-in."

0
NJComputerNetworksCommented:
wow... so it was a network resolution type issue...

0
mikechadwickCIOAuthor Commented:
Yes, as far as running the remote admin tools, but I'm still getting the same error on all machines now.
0
mikechadwickCIOAuthor Commented:
Last night I ended up deactivating the scope, unauthorizing the server and uninstalling the DHCP role.  I rebooted the server and set everything up again from scratch.  I can now see address leases.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DHCP

From novice to tech pro — start learning today.