Dell Latitude D820 Wireless PCI Bus Conflict

Good Afternoon

Hope you can help with this, I suspect this is a ill timed hardware failure but would appreciate your input.

I have a Dell Latitude D820 laptop running Win7 32bit OS.
BIOS Version: A07

The 'Intel(R)PRO/Wireless 3945ABG #2' card has recently, inexplicably stopped working.

Error: This device cannot find enough free resources that it can use. If you want to use this device, you will need to disable one of the other devices on this system. (Code 12)

This device is conflicting on PCI Bus 12.



Here's what I've tried so far...


Checked System Information for shared/conflicting IRQs.....none shown.
Disabled various devices and restarted to isolate conflict, no luck.
Checked all drivers are up to date, reseated wireless card and checked connections.
Booted laptop on a Ubuntu Live CD, ubuntu could not even find the device.

I have another D820 with the same OS & config so I swapped out the wireless card with a known working one, no change.
Swapped hard disks, the problem stayed with the Laptop hardware.
Reset the BIOS.

The only thing I haven't done is update the BIOS as I have a working D820 on A07.

The laptop did have previous issues with a faulty wireless/bluetooth switch, but this was resolved by repolacing the motherboard mid last year.

Any ideas?


Thanks for your time.





Zen_InternetAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TobiasHolmCommented:
Hi!

The card should work in Ubuntu, but might need some config according to this thread: http://ubuntuforums.org/showthread.php?t=305662

Anyway, have you checked that the system can see the Wifi card? If you boot the Ubuntu 9.10 Desktop CD and run the following command:
$  lspci
 - what is your output?

You can also use the PCI tool on the Ultimate Boot CD (http://www.ultimatebootcd.com/download.html) to check if your computer can see the card.

Regards, Tobias
0
TobiasHolmCommented:
Maybe you've already checked the Device Manager in Win7 and can see the card there? ;)

Regards, Tobias
0
TobiasHolmCommented:
ok, you get this error message saying you have device conflicts... Ignore my previous posts...

Maybe you can try resetting the BIOS to CMOS defaults? To avoid PCI device conflicts.

But I must admit it sounds as your hardware is failing...

Regards, Tobias
0
Introducing the "443 Security Simplified" Podcast

This new podcast puts you inside the minds of leading white-hat hackers and security researchers. Hosts Marc Laliberte and Corey Nachreiner turn complex security concepts into easily understood and actionable insights on the latest cyber security headlines and trends.

Zen_InternetAuthor Commented:
Hi Tobias

Thanks for your responses,

With regards to Linux, Ubuntu didn't work 'out of the box', I had to go and get drivers and support from the software repository and made sure the Wireless check box was ticked ; ).....I didn't check output admittedly.

Yes, BIOS has already been defaulted.

When trouble shooting in Device Manager I have tried the complete uninstall, reboot, install and the same thing happens, Device Manager shows the the wireless device for a short time before it seemingly uninstalls it. Hit refresh and it refinds the device and the loop starts again.

It's worth noting that:  In all this time the Wireless status light which appears next to Bluetooth has yet to light up, when we've had this problem in the past Bluetooth has also been affected, in this case BlueT is absolutely fine.

I'll try the ultimateboot CD, as the laptop is no longer in warranty it's worth checking every avenue...

Thanks again...
0
TobiasHolmCommented:
Do you have other computers of the same brand/model? Then maybe you could try replacing the Wifi card in the computer with another one from another PC?

Or you could switch the harddrives of two computers with the same hardware to see if the problem is software or hardware related.

Regards, Tobias
0
Zen_InternetAuthor Commented:
Hi Tobias

Yes, I've already done those tests.... no luck.

After spending the best part of a day trouble shooting this, it now looks like a definate motherboard failure... the switch on the side of the laptop now makes the bluetooth light flicker if it's tapped.

Thanks for all your suggestions, they are appreciated.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Laptops Notebooks

From novice to tech pro — start learning today.