MS Exchange 2003 - Enforce SPF

I have an MS Exchange 2003 server in an AD...

How can I enforce the SPF?
agortsAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
Alan HardistyConnect With a Mentor Co-OwnerCommented:
Your email states that you have Symantec Mail Security for Microsoft Exchange installed and that you have Service Pack 2 installed.
Please read the following article from Symantec for details of how to prevent Spoofed mail via their software which will be preventing you from setting this on the Exchange server:
http://service1.symantec.com/SUPPORT/ent-gate.nsf/docid/2008121815234654
This references the following article to setup a filter:
http://service1.symantec.com/SUPPORT/ent-gate.nsf/docid/2008121815164254?Open&seg=ent
Please post any more replies on EE so that the question does not get too one-sided.
Thanks
Alan
0
 
Rick FeeMessaging Engineer - Disaster Recovery EngineerCommented:
Well not really you can setup a SPF record for your domain(s) but that will depend if the recipenet mail servers do a spf lookup...
For your server to do SPF lookups...here you go:  
http://www.msexchange.org/articles/SPF-support-Exchange-freeware.html
 
0
 
agortsAuthor Commented:
Do I have to purchase GFI Mail Essential???

Is SPF supported by the Exchange 2003? Do I need something extra?
0
SMB Security Just Got a Layer Stronger

WatchGuard acquires Percipient Networks to extend protection to the DNS layer, further increasing the value of Total Security Suite.  Learn more about what this means for you and how you can improve your security with WatchGuard today!

 
Alan HardistyCo-OwnerCommented:
Make sure you have Exchange 2003 Service Pack 2 installed and then read through this article to configure Sender ID Filtering:
http://www.msexchange.org/tutorials/Configuring-enabling-Sender-ID-filtering-Exchange-2003-SP2.html
You don't need to buy 3rd party software to make this work.
0
 
agortsAuthor Commented:
I have enabled the "Apply sender ID filter" in the SMTP virtual server of a specific mail server...
I selected "reject..." in Sender ID Filtering tab of properties of Message Delivery...
I do a telnet xxx 25 in this server, from outside the local network (from the internet) and send an email with "mail from" as xxx@YYY.com (where YYY.com is the domain name which this email server serves...)...
The email delivers to xxx (me)...
It looks like it is not working (the SPF filter)...

Any ideas?
0
 
Alan HardistyCo-OwnerCommented:
Have you got an SPF record setup?
0
 
agortsAuthor Commented:
Yes I have already set it up and checked...
0
 
Alan HardistyCo-OwnerCommented:
Would you like to drop me an email with your domain name, IP address and email address in so that I can check your domain settings and test from my IP address.  If so, please email me at alanhardisty @ experts-exchange.com.
0
 
Alan HardistyCo-OwnerCommented:
Thanks for your email.  SPF is setup happily, so you may not have setup / enabled Sender ID Checking properly.
You have enabled the Sender ID on the Message Delivery Section, have you enabled the Sender ID check on the SMTP Virtual Server properties> General Tab> Advanced Button> Edit Button?
 
After enabling on the SMTP Virtual Server, restart the Simple Mail Transfer Protocol service and let me know so that I / you can test again.
0
 
Alan HardistyCo-OwnerCommented:
Check also that you have Exchange 2003 SP2 installed.
Have you got any 3rd party Anti-Spam software running on the server?
0
 
agortsAuthor Commented:
It seems that do not support SPF...
0
All Courses

From novice to tech pro — start learning today.