Cisco ASA 5500 Site to Site and Remote Access VPN Configuration Issues

I am having issues setting up a VPN to another companies network.  We currently have the Remote Access up and working for our clients.  This is tested as working.  I was sent a configuration list to connect site-to-site for the company we can not connect to.  I went through the VPN wizard in the GUI and it didn't work.  I then tried to manually setup the site-to-site in the CLI, but then it broke the remote access vpn and still wouldn't connect to  the remote company.

For the site-to-site VPN, the company has a server at 192.168.50.100 that we need to access.  They gave us their remote public ip address and it is pingable.  They then told us that we need to set our local network as 10.1.0.205/32,  and that we will need to NAT interesting traffic to 10.1.0.205/32.  They also said that we will need to make an IPSec ACL from 10.1.0.205/32 to remote network 192.168.50.0/24.  

In addition, they gave us the authentication information for phase1 and phase 2 as follows:
Phase1:
Authentication: Pre-Shared
Encryption: 3DES
Hash: SHA
DH: 1
Lifetime: 86400 sec

Phase2:
ESP encryption: 3DES
ESP authentication: SHA
Lifetime: 28800
PFS: Disabled

So it seems I have stumped the experts... Does this mean I get a refund?
ciscoasa# show run
: Saved
:
ASA Version 7.2(2) 
!
hostname ciscoasa
domain-name default.domain.invalid
enable password 1N13LocgBffkO053 encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address x.x.11.108 255.255.255.0 
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
<--- More --->              !
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd N7FecZuSHJlVZC2P encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name default.domain.invalid
access-list inside_nat0_outbound extended permit ip any 192.168.1.128 255.255.255.192 
access-list inside_nat0_outbound extended permit ip host 10.1.0.205 192.168.50.0 255.255.255.0 
access-list Local_LAN_Access remark Beaver VPN Client Local LAN Access
access-list Local_LAN_Access standard permit host 0.0.0.0 
access-list 1 extended permit ip 192.168.1.0 255.255.255.0 host 10.1.0.205 
access-list outside_access_in extended permit ip any any 
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool VPN4CLIENTS 192.168.1.151-192.168.1.160 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any outside
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
global (inside) 1 interface
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 208.88.11.108 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
group-policy WHVPN internal
group-policy WHVPN attributes
 dns-server value 192.168.1.2 8.8.8.8
 vpn-tunnel-protocol IPSec 
split-tunnel-policy excludespecified
 split-tunnel-network-list value Local_LAN_Access
 default-domain value CCIOWH
group-policy WHVPN-1 internal
group-policy WHVPN-1 attributes
 dns-server value 8.8.8.8 8.8.4.4
 vpn-tunnel-protocol IPSec 
group-policy WHVPN_1 internal
group-policy WHVPN_1 attributes
 dns-server value 192.168.1.2
 vpn-tunnel-protocol IPSec 
group-policy NewGrp internal
group-policy NewGrp attributes
 vpn-tunnel-protocol IPSec l2tp-ipsec 
username user1 password /paswordhash/ encrypted privilege 0
username user1 attributes
 vpn-group-policy WHVPN
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec transform-set myset esp-3des esp-sha-hmac 
crypto dynamic-map outside_dyn_map 20 set pfs 
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 20 set security-association lifetime seconds 288000
crypto dynamic-map outside_dyn_map 20 set reverse-route
crypto map outside_map 20 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto map inside_map interface inside
crypto isakmp enable outside
crypto isakmp policy 30
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
tunnel-group EMDs type ipsec-l2l
tunnel-group EMDs general-attributes
 default-group-policy NewGrp
tunnel-group EMDs ipsec-attributes
pre-shared-key *
tunnel-group WHVPN type ipsec-ra
tunnel-group WHVPN general-attributes
 address-pool VPN4CLIENTS
 default-group-policy WHVPN
tunnel-group WHVPN ipsec-attributes
 pre-shared-key *
tunnel-group x.x.80.108 type ipsec-l2l
tunnel-group x.x.80.108 ipsec-attributes
 pre-shared-key *
telnet 192.168.1.4 255.255.255.255 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 inside
ssh timeout 5
console timeout 0
dhcpd dns 192.168.1.2
dhcpd auto_config outside
!
dhcpd address 192.168.1.100-192.168.1.150 inside
dhcpd dns 192.168.1.2 interface inside
 dhcpd enable inside
!
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny 
  inspect sunrpc 
  inspect xdmcp 
inspect sip 
  inspect netbios 
  inspect tftp 
  inspect icmp 
  inspect icmp error 
!
service-policy global_policy global
prompt hostname context 
Cryptochecksum:ae3af8106ea61221c45594ffc4868f1a
: end

Open in new window

LVL 1
zatara1Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

zatara1Author Commented:
Doesn't anyone have any ideas on this?  Or even a direction to take?
0
Markus BraunCEOCommented:
hi,
i am guessing the reason why it wasnt working with the wizard is because the wizard cannot do the required nat that you need to do.
 what they ment with this
and that we will need to NAT interesting traffic to 10.1.0.205/32
is that your LAN ip 192.168.1.x is probably used by some other tunnel already on their end (as it is a pretty common ip address)
so they want you to make the asa do the following
your LAN IP 192.168.1.x wants to connect to their LAN IP 192.168.50.x
for this to work, the ASA has to "pretend" that you LAN IP is 10.1.0.205/32
that is done with the NAT command
e.g.
access-list inside_nat_static_1 extended permit ip 192.168.1.0 255.255.255.0 192.168.50.0 255.255.255.0
then you need to tell the ASA when to use NAT by using this
static (inside,outside) 10.1.0.205  access-list inside_nat_static_1
now
the crypto access-list needs to be like that
access-list VPN2CUSTOMER extended permit ip 10.1.0.205 255.255.255.255 192.168.50.0 255.255.255.0
so if you use the wizard for vpn, as your LAN network you need to enter the 10.1.0.205 and not 192.168.1.1
the rest of the wizard, well you got all the parameters and it should not be a problem

also
what is this for "global (inside) 1 interface " it kinda collides with the other global statement
and
this is also not a good idea
access-list outside_access_in extended permit ip any any

i hope this helps
0
zatara1Author Commented:
I am going to test it out in just a bit and will get back to you shortly.  This sounds logical and I think it is the steps I need to complete it!  Also I am not sure why those rules are in the router... I inherited this project and am not the most switch with ASA.

Thanks for your response!

Mike
0
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

zatara1Author Commented:
When I put in this line:
static (inside,outside) 10.1.0.205  access-list inside_nat_static_1

I get the following:
global address overlaps with mask

Any ideas?
0
zatara22Commented:
The problem was with the instructions.  The issue was that 10.1.0.205/32 was not the network for which traffic should be natted across, but rather it is the host on the 10.1.0.0/24 network.  I then used the following:
access-list outside_cryptomap_1 extended permit ip host 10.1.0.205 192.168.50.0 255.255.255.0
access-list outside_cryptomap_1 extended permit ip 192.168.1.0 255.255.255.0 192.168.50.0 255.255.255.0
global (inside) 10 10.1.0.205
nat (inside) 10 access-list outside_cryptomap_1
crypto map outside_map 1 match address outside_cryptomap_1

Basically what this does is say, traffic going from inside network to their local network is permitted.  Then it says if it is permitted and destined for the other sides lan, then it needs to be nat'd through 10.1.0.205 host.  And viola!  IT WORKS!  RTFM + Assuming the other side vpn creator is an idiot (if it is not you) really works!  Never trust configuration instructions.  Do your homework!

-Z

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
zatara1Author Commented:
Finally got it working thanks to this!!!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cisco

From novice to tech pro — start learning today.