FLEX Crossdomain Issue - "...is denied due to lack of policy file permissions"

I recently converted several HTTP based web services to use HTTPS on a new domain within my server. I also created a new flex project and re-imported the services via the Import->Web Service wizard with out any issue. When I attempt to debug the application locally I receive the following error:

Error: Request for resource at https://www.mydomain.com/path/to/service.asmx by requestor from http://localhost:3000/MyFlexApp/flex_bin/MyFlexApp.swf is denied due to lack of policy file permissions.

How do I allow localhost access to these services for testing/debugging purposes?

Here is my crossdomain.xml
<?xml version="1.0"?>
<!DOCTYPE cross-domain-policy SYSTEM
"http://www.adobe.com/xml/dtds/cross-domain-policy.dtd">
<cross-domain-policy>
      <site-control permitted-cross-domain-policies="master-only"/>
      <allow-access-from domain="*" to-ports="*" secure="false" />
</cross-domain-policy>

Also, if upload a Release Build of my project and run it from the server it works fine.

Thanks in advance for you help.
rwhitlatchAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sunsonmaheshCommented:
Hi,

following might be solve ur problem....

right click the flash content->settings->privacy(second tab)->advanced setting

this will open adobe flash setting web page

in that click "Global Security Settings Panel" link ->click 'edit location' drop down list->add location

--mahe
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rwhitlatchAuthor Commented:
mahe,

I tried adding both the l local swf file and the wsdl to the 'Global Security Settings Panel' but it did not have any affect. I still receive the same error message.

thanks,

rw
0
rwhitlatchAuthor Commented:
a
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Languages and Standards

From novice to tech pro — start learning today.