Cisco 1800 series DHCP config for ISP

I want one of the interfaces on my router to be configured for DHCP.  I can't get this working though.

lanvancouver#show ip int bri
Interface                  IP-Address      OK? Method Status                Prot
ocol
FastEthernet0/0            192.168.12.252  YES manual up                    up

FastEthernet0/1            unassigned      YES DHCP   up                    up

NVI0                       unassigned      YES unset  up                    up

It says DHCP, but unassigned IP address.  This is connecting to a telus DSL modem.
LVL 1
elanopsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Justin EllenbeckerIT DirectorCommented:
Does your DSL modem remember the last Mac address that was registered some ISPs will not let a new device get the IP unless you manually release the old one or wait for the lease to expire.
0
elanopsAuthor Commented:
I'm not sure... can I reset the modem somehow?  It's a Telus modem.
0
Justin EllenbeckerIT DirectorCommented:
I know all providers are different but with some of them around here in my area all you have to do is unplug the modem for at least 1 minute and that will clear its mac table and a new device can have the external IP.  What device was the external IP going to before this router was put into place?
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

elanopsAuthor Commented:
Most likely the same router
0
elanopsAuthor Commented:
I left the router unplugged for about 2 hours and tried plugging it in again to no avail.  What else can my problem be?  Here is the config for the interface:

FastEthernet0/1 is up, line protocol is up
  Internet address will be negotiated using DHCP
  Broadcast address is 255.255.255.255
  MTU is 1500 bytes
  Helper address is not set
  Directed broadcast forwarding is disabled
  Outgoing access list is not set
  Inbound  access list is 103
  Proxy ARP is disabled
  Local Proxy ARP is disabled
  Security level is default
  Split horizon is enabled
  ICMP redirects are never sent
  ICMP unreachables are never sent
  ICMP mask replies are never sent
  IP fast switching is enabled
  IP fast switching on the same interface is disabled
  IP Flow switching is enabled
  IP CEF switching is disabled
  IP Selective flow switching turbo vector
  IP multicast fast switching is enabled
  IP multicast distributed fast switching is disabled
  IP route-cache flags are Fast, Flow cache, Subint Flow
  Router Discovery is disabled
  IP output packet accounting is disabled
  IP access violation accounting is disabled
  TCP/IP header compression is disabled
  RTP/IP header compression is disabled
  Policy routing is disabled
  Network address translation is enabled, interface in domain outside
  BGP Policy Mapping is disabled

show ip int bri:

Interface                  IP-Address      OK? Method Status                Prot
ocol
FastEthernet0/0            192.168.12.252  YES manual up                    up

FastEthernet0/1            unassigned      YES DHCP   up                    up

NVI0                       unassigned      YES unset  up                    up
0
Justin EllenbeckerIT DirectorCommented:
can you please post the whole show run, and did you unplug the modem at all or just the router?
0
elanopsAuthor Commented:
I unplugged the modem.

Here is the full running config:

Current configuration : 6642 bytes
!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname #############
!
boot-start-marker
boot-end-marker
!
security authentication failure rate 3 log
security passwords min-length 6
logging buffered 51200 debugging
logging console critical
enable secret 5 ###################
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local
!
aaa session-id common
!
resource policy
!
clock timezone PCTime -8
clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
no ip source-route
no ip routing
no ip cef
!
!
ip tcp synwait-time 10
no ip dhcp use vrf connected
!
!
ip ftp username dailies
ip ftp password 7 03115502120A25424F1D100A1901
no ip bootp server
ip domain name dyndns.org
ip name-server #########
ip name-server #########
ip ddns update method sdm_ddns1
 HTTP
  add http://########@members.dyndns.org/nic/update?system=dyndns&h
ostname=<h>&myip=<a>
  remove ##########@members.dyndns.org/nic/update?system=dyndn
s&hostname=<h>&myip=<a>
!
!
username ####### privilege 15 secret 5 ###################
!
!
!
interface FastEthernet0/0
 description $ETH-SW-LAUNCH$$INTF-INFO-FE 0$$ES_LAN$$FW_INSIDE$$ETH-LAN$
 ip address 192.168.12.252 255.255.255.0
 ip access-group 102 in
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 ip flow egress
 ip nat inside
 duplex auto
 speed auto
 no mop enabled
!
interface FastEthernet0/1
 description Telus
 ip dhcp client update dns
 ip address dhcp client-id FastEthernet0/1 hostname elanvancouver-backup
 ip access-group 103 in
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 ip flow egress
 ip nat outside
!
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1 permanent
ip flow-top-talkers
 top 10
 sort-by bytes
!
ip http server
ip http authentication local
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 1 interface FastEthernet0/1 overload
ip nat inside source static udp ######## 22 interface FastEthernet0/1 2222

ip nat inside source static tcp ######## 22 interface FastEthernet0/1 2222

ip nat inside source static tcp ######## 1723 interface FastEthernet0/1 17
23
ip nat inside source static udp ######## 22 interface FastEthernet0/1 22
ip nat inside source static tcp ######## 22 interface FastEthernet0/1 22
ip nat inside source static udp ######## 20610 interface FastEthernet0/1 2
0610
ip nat inside source static tcp ######## 8075 interface FastEthernet0/1 80
75
8902
ip nat inside source static udp ######## 7767 interface FastEthernet0/1 77
67
ip nat inside source static udp ######## 7758 interface FastEthernet0/1 77
58
ip nat inside source static udp ######## 7757 interface FastEthernet0/1 77
57
ip nat inside source static tcp ######## 3390 interface FastEthernet0/1 33
94
ip nat inside source static tcp ######## 3389 interface FastEthernet0/1 33
91
ip nat inside source static tcp ######## 3389 interface FastEthernet0/1 33
92
ip nat inside source static tcp ######## 3389 interface FastEthernet0/1 33
93
ip nat inside source static tcp ######## 3389 interface FastEthernet0/1 33
90
ip nat inside source static tcp ######## 995 interface FastEthernet0/1 995
ip nat inside source static tcp ######## 110 interface FastEthernet0/0 110
ip nat outside source static tcp ######## 110 ######## 110 extendable

!
logging trap debugging
access-list 1 remark INSIDE_IF=FastEthernet0/0
access-list 1 remark SDM_ACL Category=2
access-list 1 permit ######## 0.0.0.255
access-list 102 remark auto generated by SDM firewall configuration
access-list 102 remark SDM_ACL Category=1
access-list 102 permit ip any any
access-list 103 remark auto generated by SDM firewall configuration
access-list 103 remark SDM_ACL Category=1
access-list 103 remark SFTP
access-list 103 permit udp any host ######## eq 22
access-list 103 permit udp host ######## eq domain host ########
access-list 103 permit udp host ######## eq domain host ########
access-list 103 deny   ip 192.168.12.0 0.0.0.255 any
access-list 103 permit icmp any host ######## echo-reply
access-list 103 permit icmp any host ######## time-exceeded
access-list 103 permit icmp any host ######## unreachable
access-list 103 remark HTTPS
access-list 103 permit tcp any host ######## eq 443
access-list 103 remark SFTP
access-list 103 permit tcp any host ######## eq 22
access-list 103 remark SSL
access-list 103 permit tcp any host ######## eq 2222
access-list 103 remark SSL
access-list 103 permit udp any host ############# eq 2222
access-list 103 remark FTP
access-list 103 permit tcp any host ############# eq ftp
access-list 103 remark FTP
access-list 103 permit udp any host ############# eq 21
access-list 103 remark VPN
access-list 103 permit gre any host #############
access-list 103 remark VPN
access-list 103 permit tcp any host ############# eq 1723
access-list 103 permit tcp any host ############# eq cmd
access-list 103 remark Remote Desktop
access-list 103 permit tcp any host ############# range 3390 3394
access-list 103 permit udp any host ############# eq 7758
access-list 103 permit udp any host ############# eq 7757
access-list 103 permit udp any host ############# eq 7767
access-list 103 permit tcp any host ############# eq 28902
access-list 103 permit tcp any host ############# eq 8075
access-list 103 permit udp any host ############# eq 20610
access-list 103 deny   ip 10.0.0.0 0.255.255.255 any
access-list 103 deny   ip ############# 0.15.255.255 any
access-list 103 deny   ip ############# 0.0.255.255 any
access-list 103 deny   ip ############# 0.255.255.255 any
access-list 103 deny   ip host 255.255.255.255 any
access-list 103 deny   ip host 255.255.255.255 any
access-list 103 deny   ip host 0.0.0.0 any
access-list 103 deny   ip any any log
snmp-server community public RO
snmp-server location #############
snmp-server contact #############
no cdp run
!
control-plane
!
banner login #############
!
line con 0
 transport output telnet
line aux 0
 transport output telnet
line vty 0 4
 password 7 151E070D092B202D3B20212A0B
line vty 5 15
!
scheduler allocate 4000 1000
end
0
OzNetNerdCommented:
Try using the following commands:

interface FastEthernet0/1
 ip address dhcp
0
OzNetNerdCommented:
Sorry, try this:

interface FastEthernet0/1
 no  ip address dhcp client-id FastEthernet0/1 hostname elanvancouver-backup
 ip address dhcp
0
Justin EllenbeckerIT DirectorCommented:
Thanks for posting the running config,  I just had a chance to go over it and agree with bbd that the ID may be screwing it up.  The commands will take it to stock DHCP and we'll go from there.
0
elanopsAuthor Commented:
Okay I did as you said and STILL it says "unassigned",  I tried unplugging the modem for 1 minute as well.  I also tried unplugging the incoming connection to the cisco router and plugging it into a laptop.... which... surprise! Worked.
0
elanopsAuthor Commented:
I just did a show ip int and found this on my fa0/1 interface:
"Internet protocol processing disabled"

Seems like something I'd want enabled...
Also this seems totally wrong...

"elanvancouver#sh ip route
Default gateway is not set

Host               Gateway           Last Use    Total Uses  Interface
ICMP redirect cache is empty"
0
elanopsAuthor Commented:
This is interesting.  I turned on debugging and got this:

------------------------------------------------------
003590: *Mar 24 09:52:46.433 PCTime: DHCP: SDiscover attempt # 3 for entry:
003591: *Mar 24 09:52:46.433 PCTime: Temp IP addr: 0.0.0.0  for peer on Interface: FastEthernet0/1
003592: *Mar 24 09:52:46.433 PCTime: Temp  sub net mask: 0.0.0.0
003593: *Mar 24 09:52:46.433 PCTime:    DHCP Lease server: 0.0.0.0, state: 1 Selecting
003594: *Mar 24 09:52:46.433 PCTime:    DHCP transaction id: 2407
003595: *Mar 24 09:52:46.433 PCTime:    Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs
003596: *Mar 24 09:52:46.433 PCTime:    Next timer fires after: 00:00:04
003597: *Mar 24 09:52:46.433 PCTime:    Retry count: 3   Client-ID: cisco-001d.70f6.6d49-Fa0/1
003598: *Mar 24 09:52:46.433 PCTime:    Client-ID hex dump: 636973636F2D303031642E373066362E
003599: *Mar 24 09:52:46.433 PCTime:                        366434392D4661302F31
003600: *Mar 24 09:52:46.433 PCTime:    Hostname: elanvancouver
003601: *Mar 24 09:52:46.433 PCTime: DHCP: Including FQDN option with hostname elanvancouver flags 0x4
003602: *Mar 24 09:52:46.433 PCTime: DHCP: SDiscover: sending 321 byte length DHCP packet
003603: *Mar 24 09:52:46.433 PCTime: DHCP: SDiscover 321 bytes
003604: *Mar 24 09:52:46.433 PCTime:             B'cast on FastEthernet0/1 interface from 0.0.0.0
003605: *Mar 24 09:52:50.433 PCTime: DHCP: QScan: Timed out Selecting state
-----------------------------------


any thoughts?
0
Justin EllenbeckerIT DirectorCommented:
This is a shot in the dark but for the heck of it reconnect the laptop while it is connected open a command prompt and type "ipconfig /release" then unplug it abd plug the cisco in with debugging on for DHCP and post the full output while it goes through the process please.  Also please remove the access list for inbound on the adapter lets take it back to as plain as we can and build on it from there.
0
elanopsAuthor Commented:
Laptop runs linux :P.  

I did a lot of research, it seems to possibly be telus' problem.  If I go to their site with the cisco router connected, it says no devices are connected.  If I go to the site with my laptop connected it returns my laptops MAC address.

Another post (found here, last post: https://supportforums.cisco.com/thread/343375;jsessionid=A5CF44116F6D6481EB64C42B6DC3227A.node0) has a similar problem except his mac address is showing up.

Is there a configuration that possibly restricts the router from giving it's mac address?
0
Justin EllenbeckerIT DirectorCommented:
You can always try the mac address line and assign the cisco the laptops mac
0
Justin EllenbeckerIT DirectorCommented:
mac-address XXXX.XXXX.XXXX
0
elanopsAuthor Commented:
thanks :) I'll give that a shot.
0
Justin EllenbeckerIT DirectorCommented:
Put that on F0/1 and see what happens,  I had to do this with my linksys at home to use it as an AP because my provider requires the MAC of the device since they do reservations.
0
elanopsAuthor Commented:
no dice, didnt work.
0
Justin EllenbeckerIT DirectorCommented:
i would get on the phone with Telus at this point and tell them exactly what is going on, that you can use the laptop with no issue but cannot hook up a router at all they should be able to check the DHCP logs on their side and see as well.
0
Justin EllenbeckerIT DirectorCommented:
Sorry not Telus though that as the ISP but its the modem I meant the ISP
0
elanopsAuthor Commented:
your second comment there just completely confuses me and makes no sense lol.

I tried phoning them earlier and the guy was an idiot.  I tried describing the issue and all he said was that it should "just work" and "no nothing is wrong on our end".  Perhaps I'll get a more intelligent person to talk to this time.....

Are you sure there's nothing wrong with my configs? If my laptop's MAC is picked up, how come my routers isn't?
0
OzNetNerdCommented:
"Are you sure there's nothing wrong with my configs? If my laptop's MAC is picked up, how come my routers isn't?"

So when your laptop is directly connected to the modem, it does work, but when connected to the router, it doesn't?
0
elanopsAuthor Commented:
That's exactly correct.
0
Justin EllenbeckerIT DirectorCommented:
But we have tried placing the laptops mac on the int also did you take off the ACL off temporarily?  The next option is to export the config to a tftp server and then do a write erase and starting pluggin the config in little by little until you get to the part where it is broken.  Odds are it is something on the interface itself and you may be able to just return that interface to its defaults.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Justin EllenbeckerIT DirectorCommented:
Also not sure how i missed this but you have "no ip routing" you need ip routing since so please do this:

conf t
ip routing
exit

That shouldn't affect DHCP on the interface side but it might, and its something you will need anyways since you are doing NAT.
0
elanopsAuthor Commented:
Thanks for your help but I "figured it out".  Kind of.  Haha. I erased all the configs and started from scratch and it's working fine.
0
Justin EllenbeckerIT DirectorCommented:
Sometimes that is the best option get a good backup and go over it line by line testing it as you go.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.