• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1204
  • Last Modified:

Error static route cisco asa 5505

Hi,

I created a static route from my lan 192.168.10.0 to other lan  192.168.9.0

the two lan´s are in vpn but not a lan to lan cisco asa vpn.

I can pass icmp traffic but i can´t pass other kind of traffic. The log said:

192.168.10.10      192.168.9.69       Built inbound TCP connection 493601 for inside:192.168.10.10/4186 (192.168.10.10/4186) to inside:192.168.9.69/5900 (192.168.9.69/5900)

192.168.10.10      192.168.9.69       Teardown TCP connection 493601 for inside:192.168.10.10/4186 to inside:192.168.9.69/5900 duration 0:00:00 bytes 0 TCP Reset-O

for test i want to connect to vnc server...

other configuration that i make is to configure a static route in windows,

route add 192.168.9.0 mask 255.255.255.0 192.168.10.240 ....  and all work perfect.


thanks a lot...
: Saved
:
ASA Version 7.2(4) 
!
hostname ciscoasa
domain-name default.domain.invalid
enable password EhxQ5dBfvkyaUj52 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
name 192.168.10.8 W2K3-X32-SP
name X.X.X.201 www.X.X.X.net
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.10.1 255.255.255.0 
 ospf cost 10
!
interface Vlan2
 nameif outside
 security-level 0
 ip address X.X.X.194 255.255.255.240 
 ospf cost 10
!
interface Vlan3
 no forward interface Vlan1
 nameif dmz
 security-level 50
 ip address 192.168.12.1 255.255.255.0 
 ospf cost 10
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
 switchport access vlan 3
!
ftp mode passive
dns domain-lookup inside
dns domain-lookup outside
dns server-group DNS1
 name-server W2K3-X32-SP
dns server-group DefaultDNS
 timeout 30
 name-server W2K3-X32-SP
 domain-name default.domain.invalid
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group protocol TCPUDP
 protocol-object udp
 protocol-object tcp
access-list outside_access_in extended permit ip any any 
access-list outside_access_in extended permit tcp any interface outside eq 3389 
access-list INSIDE_ACL_OUT extended permit ip any any 
access-list 100 extended permit udp any any eq domain 
access-list 100 extended permit tcp any any eq ftp 
access-list 100 extended permit tcp any any eq ftp-data 
access-list 100 extended permit tcp any any eq https 
access-list 100 extended permit tcp any any eq 3389 
access-list 100 extended permit tcp any any eq www 
access-list 100 extended permit icmp any any inactive 
access-list inside_access_in extended permit ip any any 
access-list inbound extended permit tcp any interface outside eq 3389 
access-list RDP extended permit tcp any interface outside eq 3389 log 
access-list RDP extended permit tcp interface outside interface inside eq 3389 
access-list outside_5_cryptomap extended permit ip 192.168.10.0 255.255.255.0 192.168.9.0 255.255.255.0 
access-list inside_nat0_outbound extended permit ip 192.168.10.0 255.255.255.0 192.168.5.0 255.255.255.0 
access-list inside_nat0_outbound extended permit ip 192.168.10.0 255.255.255.0 192.168.1.0 255.255.255.0 
access-list inside_nat0_outbound extended permit ip 192.168.10.0 255.255.255.0 192.168.4.0 255.255.255.0 
access-list inside_nat0_outbound extended permit ip 192.168.10.0 255.255.255.0 192.168.9.0 255.255.255.0 
access-list outbound extended permit ip any any 
access-list outside_2_cryptomap extended permit ip 192.168.10.0 255.255.255.0 192.168.5.0 255.255.255.0 
access-list outside_3_cryptomap extended permit ip 192.168.10.0 255.255.255.0 192.168.1.0 255.255.255.0 
access-list outside_4_cryptomap extended permit ip 192.168.10.0 255.255.255.0 192.168.4.0 255.255.255.0 
pager lines 24
logging enable
logging asdm informational
logging from-address cisco@X.X.X.com
logging recipient-address javier.gonzalez@X.X.X.com level errors
mtu inside 1500
mtu outside 1500
mtu dmz 1500
ip local pool pool1 192.168.10.70-192.168.10.75 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 X.X.X.195-X.X.X.206 netmask 255.255.255.240
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 192.168.10.0 255.255.255.0
static (inside,outside) tcp www.X.X.X.net ftp 192.168.10.10 ftp netmask 255.255.255.255 
static (inside,outside) tcp www.X.X.X.net ftp-data 192.168.10.10 ftp-data netmask 255.255.255.255 
static (inside,outside) tcp X.X.X.17 3389 192.168.10.9 3389 netmask 255.255.255.255 
static (inside,outside) tcp X.X.X.0 https 192.168.10.9 https netmask 255.255.255.255 
static (inside,outside) tcp www.X.X.X.net https W2K3-X32-SP https netmask 255.255.255.255 
static (inside,outside) tcp www.X.X.X.net www W2K3-X32-SP www netmask 255.255.255.255 
static (inside,outside) udp www.X.X.X.net domain W2K3-X32-SP domain netmask 255.255.255.255 
static (inside,outside) tcp www.X.X.X.net domain W2K3-X32-SP domain netmask 255.255.255.255 
static (inside,outside) tcp X.X.X.198 https 192.168.10.13 https netmask 255.255.255.255 
static (inside,outside) tcp X.X.X.202 3389 192.168.10.10 3389 netmask 255.255.255.255 
static (inside,outside) tcp X.X.X.200 www 192.168.10.14 www netmask 255.255.255.255 
access-group outbound in interface inside
access-group 100 in interface outside
route inside 192.168.9.0 255.255.255.0 192.168.10.240 1
route outside 0.0.0.0 0.0.0.0 X.X.X.193 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http X.X.X.194 255.255.255.255 outside
http 192.168.10.0 255.255.255.0 inside
http 192.168.1.0 255.255.255.255 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set TRANS_ESP_3DES_SHA esp-3des esp-sha-hmac 
crypto ipsec transform-set TRANS_ESP_3DES_SHA mode transport
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec transform-set ESP-3DES-NOAUT esp-3des esp-none 
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto map outside_map 2 match address outside_2_cryptomap
crypto map outside_map 2 set peer X.2.X.218 
crypto map outside_map 2 set transform-set ESP-3DES-SHA
crypto map outside_map 2 set security-association lifetime seconds 172800
crypto map outside_map 3 match address outside_3_cryptomap
crypto map outside_map 3 set peer X.4.X.149 
crypto map outside_map 3 set transform-set ESP-3DES-SHA
crypto map outside_map 3 set security-association lifetime seconds 172800
crypto map outside_map 4 match address outside_4_cryptomap
crypto map outside_map 4 set peer X.X.X.X 
crypto map outside_map 4 set transform-set ESP-3DES-SHA
crypto map outside_map 4 set security-association lifetime seconds 172800
crypto map outside_map interface outside
crypto isakmp enable inside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 80000
crypto isakmp policy 30
 authentication pre-share
 encryption 3des
 hash sha
 group 1
 lifetime 172800
crypto isakmp nat-traversal  15
crypto isakmp disconnect-notify
crypto isakmp reload-wait
telnet timeout 5
ssh timeout 5
console timeout 0
l2tp tunnel hello 120
dhcpd auto_config outside
!
dhcpd address 192.168.10.90-192.168.10.100 inside
dhcpd dns 154.15.255.134 154.15.255.130 interface inside
dhcpd enable inside
!

group-policy DefaultRAGroup internal
group-policy DefaultRAGroup attributes
 vpn-idle-timeout none
 vpn-session-timeout none
 vpn-tunnel-protocol IPSec l2tp-ipsec 
group-policy DfltGrpPolicy attributes
 banner none
 wins-server none
 dns-server none
 dhcp-network-scope none
 vpn-access-hours none
 vpn-simultaneous-logins 3
 vpn-idle-timeout none
 vpn-session-timeout none
 vpn-filter none
 vpn-tunnel-protocol IPSec l2tp-ipsec webvpn
 password-storage disable
 ip-comp disable
 re-xauth disable
 group-lock none
 pfs disable
 ipsec-udp disable
 ipsec-udp-port 10000
 split-tunnel-policy tunnelall
 split-tunnel-network-list none
 default-domain none
 split-dns none
 intercept-dhcp 255.255.255.255 disable
 secure-unit-authentication disable
 user-authentication disable
 user-authentication-idle-timeout none
 ip-phone-bypass disable
 leap-bypass disable
 nem disable
 backup-servers keep-client-config
 msie-proxy server none
 msie-proxy method no-modify
 msie-proxy except-list none
 msie-proxy local-bypass disable
 nac disable
 nac-sq-period 300
 nac-reval-period 86400
 nac-default-acl none
 address-pools none
 smartcard-removal-disconnect enable
 client-firewall none
 client-access-rule none
 webvpn
  functions url-entry
  html-content-filter none
  homepage none
  keep-alive-ignore 4
  http-comp gzip
  filter none
  url-list none
  customization value DfltCustomization
  port-forward none
  port-forward-name value Application Access
  sso-server none
  deny-message value Login was successful, but because certain criteria have not been met or due to some specific group policy, you do not have permission to use any of the VPN features. Contact your IT administrator for more information
  svc none
  svc keep-installer installed
  svc keepalive none
  svc rekey time none
  svc rekey method none
  svc dpd-interval client none
  svc dpd-interval gateway none
  svc compression deflate
tunnel-group DefaultL2LGroup ipsec-attributes
 isakmp keepalive threshold 30 retry 2
tunnel-group DefaultRAGroup general-attributes
 address-pool pool1
 default-group-policy DefaultRAGroup
tunnel-group DefaultRAGroup ipsec-attributes
 pre-shared-key *
 isakmp keepalive threshold 30 retry 2
tunnel-group 8 type ipsec-l2l
tunnel-group 8 ipsec-attributes
 pre-shared-key *
tunnel-group 809 type ipsec-l2l
tunnel-group 89 ipsec-attributes
 pre-shared-key *
tunnel-group 80.1 type ipsec-l2l
tunnel-group 80.1 ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny 
  inspect sunrpc 
  inspect xdmcp 
  inspect sip 
  inspect netbios 
  inspect tftp 
  inspect dns 
!
service-policy global_policy global
smtp-server 2
prompt hostname context 
Cryptochecksum:eff7c4ca93450e10a40240e088e4aeb4
: end
asdm image disk0:/asdm-524.bin
asdm location 192.168.9.0 255.255.255.0 inside
no asdm history enable

Open in new window

Asa.JPG
Asa2.JPG
0
rauljimenez
Asked:
rauljimenez
  • 7
  • 6
1 Solution
 
arnoldCommented:
Is 192.168.10.240 your windows server on which the windows VPN terminates?
Your static route for 192.168.9.0 should be directed to 192.168.10.240. Presumably the 192.168.10.240 NATs the traffic from the VPN such that all internal sysmtes see the requests coming from 192.168.10.240.  In this case there might not be a path from the 192.168.10.x to the 192.168.9.x network.
0
 
rauljimenezAuthor Commented:
thanks,

192.168.10.240 is the gateway of my corporate vpn.

i have a static route grom 192.168.9.0 to 192.168.10.240 .

if can´t be a path from 10.x to 9.x what would be the correct path?

thanks!!
0
 
rauljimenezAuthor Commented:
sorry, i forget this,

  " In this case there might not be a path from the 192.168.10.x to the 192.168.9.x network. ". If it work properly in windows with a manually route add command...  ¿Is a valid path from 10.x to 9.x.. no?

thanks a lot!



0
Become an IT Security Management Expert

In today’s fast-paced, digitally transformed world of business, the need to protect network data and ensure cloud privacy has never been greater. With a B.S. in Network Operations and Security, you can get the credentials it takes to become an IT security management expert.

 
arnoldCommented:
Could you draw/explain your network layout
i.e. internet -> router->pix>LAN 192.168.10.x
Where does the 192.168.9.x comes from?
run on the pix:
show crypto sa summary
It is not clear whether you do or you do not have a site to site (LAN to LAN) VPN between the PIX and a remote router.
You do not have a match address outside_crypto map for 192.168.9.x.
0
 
rauljimenezAuthor Commented:
i have twh net´s. 192.168.10.0 and 192.168.9.0

Cisco asa is on 192.168.10.0 .

192.168.9.0 is a remote lan.  

In lan 192.168.10.0 i have a ip 192.168.10.240 who is the gateway for the net 192.168.9.0

i configured a static route on cisco asa 5505 and a exempt nat from inside host to 192.168.9.0

i don´t know why only can make ping´s and the other traffic´s are blocked beteewn 192.168.10.0 and 192.168.9.0 .

thanks
0
 
arnoldCommented:
The other side needs to be similarly configured on how to get back to a 192.168.10.0 network.
Is your setup at each location:

Site 1: Internet <=> router ASA<=> Windows server VPN Gateway 192.168.10.240
Site 2: Internet <=> router ASA<=> Windows server VPN Gateway 192.168.9.240

Does the site 2 router also have a static route for the 192.168.10.0 to go through 192.168.9.240 as well as have the 192.168.10.0 in the nat 0 access-list nonat?
0
 
rauljimenezAuthor Commented:
I changed the configuration, now:

Inside network 192.168.10.0 255.255.255.0

Outside network  88.88.88.0 255.255.255.0

Remote network 192.168.9.0 255.255.255.0

 
I have a problem with a dmz vlan.  I can´t surf over internet on a remote host.



The dmz vlan links with remote network on host 192.168.20.3  .

 

INSIDE (192.168.10.0) --------------  Outside (88.88.88.0)  -------------- DMZ (192.168.20.0)
                                                                                                  ^
                                                                                                  |---------- Remote network (192.168.9.0)

 thanks!
: Saved
:
ASA Version 7.2(4) 
!
hostname ciscoasa
domain-name default.domain.invalid
enable password EhxQ5dBfvkyaUj52 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
name 192.168.10.8 W2K3-X32-SP
name 88.88.88.201 www.xxxx.com
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.10.1 255.255.255.0 
 ospf cost 10
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 88.88.88.194 255.255.255.240 
 ospf cost 10
!
interface Vlan3
 no forward interface Vlan1
 nameif dmz
 security-level 50
 ip address 192.168.20.1 255.255.255.0 
 ospf cost 10
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
 switchport access vlan 3
!
ftp mode passive
dns domain-lookup inside
dns domain-lookup outside
dns server-group DNS1
 name-server W2K3-X32-SP
dns server-group DefaultDNS
 timeout 30
 name-server W2K3-X32-SP
 domain-name default.domain.invalid
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group protocol TCPUDP
 protocol-object udp
 protocol-object tcp
access-list outside_access_in extended permit ip any any 
access-list outside_access_in extended permit tcp any interface outside eq 3389 
access-list outside_access_in extended permit object-group TCPUDP any interface dmz eq domain 
access-list INSIDE_ACL_OUT extended permit ip any any 
access-list 100 extended permit udp any any eq domain 
access-list 100 extended permit tcp any any eq ftp 
access-list 100 extended permit tcp any any eq ftp-data 
access-list 100 extended permit tcp any any eq https 
access-list 100 extended permit tcp any any eq 3389 
access-list 100 extended permit tcp any any eq www 
access-list 100 extended permit icmp any any 
access-list inside_access_in extended permit ip any any 
access-list inbound extended permit tcp any interface outside eq 3389 
access-list RDP extended permit tcp any interface outside eq 3389 log 
access-list RDP extended permit tcp interface outside interface inside eq 3389 
access-list inside_nat0_outbound extended permit ip 192.168.10.0 255.255.255.0 192.168.5.0 255.255.255.0 
access-list inside_nat0_outbound extended permit ip 192.168.10.0 255.255.255.0 192.168.1.0 255.255.255.0 
access-list inside_nat0_outbound extended permit ip 192.168.10.0 255.255.255.0 192.168.4.0 255.255.255.0 
access-list outbound extended permit ip any any 
access-list outside_2_cryptomap extended permit ip 192.168.10.0 255.255.255.0 192.168.5.0 255.255.255.0 
access-list outside_3_cryptomap extended permit ip 192.168.10.0 255.255.255.0 192.168.1.0 255.255.255.0 
access-list outside_4_cryptomap extended permit ip 192.168.10.0 255.255.255.0 192.168.4.0 255.255.255.0 
access-list inside_acl extended permit ip any any 
access-list dmz_access_in extended permit ip any any 
access-list dmz_access_in extended permit icmp any any 
access-list dmz_access_in extended permit tcp any any 
pager lines 24
logging enable
logging asdm informational
logging from-address cisco@ltkgrp.com
logging recipient-address fdg@gdfr.com level errors
mtu inside 1500
mtu outside 1500
mtu dmz 1500
ip local pool pool1 192.168.10.70-192.168.10.75 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 88.88.88.195-88.88.88.206 netmask 255.255.255.240
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 192.168.10.0 255.255.255.0
nat (dmz) 1 192.168.20.0 255.255.255.0
static (inside,outside) tcp www.xxxx.com ftp 192.168.10.10 ftp netmask 255.255.255.255 
static (inside,outside) tcp www.xxxx.com ftp-data 192.168.10.10 ftp-data netmask 255.255.255.255 
static (inside,outside) tcp 88.88.88.197 3389 192.168.10.9 3389 netmask 255.255.255.255 
static (inside,outside) tcp 88.88.88.200 https 192.168.10.9 https netmask 255.255.255.255 
static (inside,outside) tcp www.xxxx.com https W2K3-X32-SP https netmask 255.255.255.255 
static (inside,outside) tcp www.xxxx.com www W2K3-X32-SP www netmask 255.255.255.255 
static (inside,outside) udp www.xxxx.com domain W2K3-X32-SP domain netmask 255.255.255.255 
static (inside,outside) tcp www.xxxx.com domain W2K3-X32-SP domain netmask 255.255.255.255 
static (inside,outside) tcp 88.88.88.198 https 192.168.10.13 https netmask 255.255.255.255 
static (inside,outside) tcp 88.88.88.202 3389 192.168.10.10 3389 netmask 255.255.255.255 
static (inside,outside) tcp 88.88.88.200 www 192.168.10.14 www netmask 255.255.255.255 
access-group 100 in interface outside
access-group dmz_access_in in interface dmz
route outside 0.0.0.0 0.0.0.0 88.88.88.193 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.255 inside
http 192.168.10.0 255.255.255.0 inside
http 88.88.88.194 255.255.255.255 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set TRANS_ESP_3DES_SHA esp-3des esp-sha-hmac 
crypto ipsec transform-set TRANS_ESP_3DES_SHA mode transport
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec transform-set ESP-3DES-NOAUT esp-3des esp-none 
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto map outside_map 2 match address outside_2_cryptomap
crypto map outside_map 2 set peer 88.2.225.218 
crypto map outside_map 2 set transform-set ESP-3DES-SHA
crypto map outside_map 2 set security-association lifetime seconds 172800
crypto map outside_map 3 match address outside_3_cryptomap
crypto map outside_map 3 set peer 80.24.224.149 
crypto map outside_map 3 set transform-set ESP-3DES-SHA
crypto map outside_map 3 set security-association lifetime seconds 172800
crypto map outside_map 4 match address outside_4_cryptomap
crypto map outside_map 4 set peer 80.37.221.171 
crypto map outside_map 4 set transform-set ESP-3DES-SHA
crypto map outside_map 4 set security-association lifetime seconds 172800
crypto map outside_map interface outside
crypto isakmp enable inside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 80000
crypto isakmp policy 30
 authentication pre-share
 encryption 3des
 hash sha
 group 1
 lifetime 172800
crypto isakmp nat-traversal  15
crypto isakmp disconnect-notify
crypto isakmp reload-wait
telnet timeout 5
ssh timeout 5
console timeout 0
l2tp tunnel hello 120
dhcpd auto_config outside
!
dhcpd address 192.168.10.90-192.168.10.100 inside
dhcpd dns 154.15.255.134 154.15.255.130 interface inside
dhcpd enable inside
!
dhcpd address 192.168.20.10-192.168.20.11 dmz
dhcpd dns 8.8.8.8 8.8.8.4 interface dmz
!

group-policy DefaultRAGroup internal
group-policy DefaultRAGroup attributes
 vpn-idle-timeout none
 vpn-session-timeout none
 vpn-tunnel-protocol IPSec l2tp-ipsec 
group-policy DfltGrpPolicy attributes
 banner none
 wins-server none
 dns-server none
 dhcp-network-scope none
 vpn-access-hours none
 vpn-simultaneous-logins 3
 vpn-idle-timeout none
 vpn-session-timeout none
 vpn-filter none
 vpn-tunnel-protocol IPSec l2tp-ipsec webvpn
 password-storage disable
 ip-comp disable
 re-xauth disable
 group-lock none
 pfs disable
 ipsec-udp disable
 ipsec-udp-port 10000
 split-tunnel-policy tunnelall
 split-tunnel-network-list none
 default-domain none
 split-dns none
 intercept-dhcp 255.255.255.255 disable
 secure-unit-authentication disable
 user-authentication disable
 user-authentication-idle-timeout none
 ip-phone-bypass disable
 leap-bypass disable
 nem disable
 backup-servers keep-client-config
 msie-proxy server none
 msie-proxy method no-modify
 msie-proxy except-list none
 msie-proxy local-bypass disable
 nac disable
 nac-sq-period 300
 nac-reval-period 86400
 nac-default-acl none
 address-pools none
 smartcard-removal-disconnect enable
 client-firewall none
 client-access-rule none
 webvpn
  functions url-entry
  html-content-filter none
  homepage none
  keep-alive-ignore 4
  http-comp gzip
  filter none
  url-list none
  customization value DfltCustomization
  port-forward none
  port-forward-name value Application Access
  sso-server none
  deny-message value Login was successful, but because certain criteria have not been met or due to some specific group policy, you do not have permission to use any of the VPN features. Contact your IT administrator for more information
  svc none
  svc keep-installer installed
  svc keepalive none
  svc rekey time none
  svc rekey method none
  svc dpd-interval client none
  svc dpd-interval gateway none
  svc compression deflate
tunnel-group DefaultL2LGroup ipsec-attributes
 isakmp keepalive threshold 30 retry 2
tunnel-group DefaultRAGroup general-attributes
 address-pool pool1
 default-group-policy DefaultRAGroup
tunnel-group DefaultRAGroup ipsec-attributes
 pre-shared-key *
 isakmp keepalive threshold 30 retry 2
tunnel-group 88.2.225.218 type ipsec-l2l
tunnel-group 88.2.225.218 ipsec-attributes
 pre-shared-key *
tunnel-group 80.24.224.149 type ipsec-l2l
tunnel-group 80.24.224.149 ipsec-attributes
 pre-shared-key *
tunnel-group 80.37.221.171 type ipsec-l2l
tunnel-group 80.37.221.171 ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny 
  inspect sunrpc 
  inspect xdmcp 
  inspect sip 
  inspect netbios 
  inspect tftp 
  inspect dns 
!
service-policy global_policy global
smtp-server 217.76.146.62
prompt hostname context 
Cryptochecksum:e4e9484e7a02b66d990eb25db1c3494a
: end
asdm image disk0:/asdm-524.bin
asdm location 192.168.9.0 255.255.255.0 inside
no asdm history enable

Open in new window

0
 
arnoldCommented:
I'm not clear on the issue. You VPN into a DMZ host and then try to browse through the DMZ'ed host?

You do not have any rules dealing with the DMZ IP range you i.e. no access-lists that would allow access from 192.168.20.x to any of the internal.

You have the dmz_access_in to allow everything in. There is no rule on what you are allowing out.
You are using nat (dmz) 1.
If you want the DMZ connection to bypass all ACL rules, you should use the
nat (dmz) 0 IPrange
0
 
rauljimenezAuthor Commented:
i have a vpn over my internet provider. I need to surf from a host of the subnet 192.168.9.0  to internet or another host inside.

My provider configure a gateway in host 192.168.20.3  

is possible that we need a static route?

0
 
arnoldCommented:
192.168.20.3 is your DMZ LAN.
192.168.9.0 Is your REMOTE LAN

I'm not sure what you are trying to do.
Are you establishing a VPN from 192.168.9.x to 192.168.20.3 and want all traffic from 192.168.9.x to travel via the VPN to 192.168.20.3 and then be allowed out through that connection to surf the net?
You would need to add the
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface

This is to allow traffic that arrived to be allowed backout.
The other option is the
sysopt connection permit-ipsec
sysopt connection permit-vpn

To get the VPN traffic to bypass the ACL.
0
 
rauljimenezAuthor Commented:
thanks arnold,

Yes, I´m stablishing a VPN from 192.168.9x to 192.168.20.3 and all traffic from 192.168.9.x travel via vpn to 192.168.20.3 ...   Asa doesn´t make de VPN, the vpn is from my provider...

the same-security-traffic permit intra-interface  command is on Asa.

0
 
arnoldCommented:
You may need to allow the sysopt directive as well as add the ACL rules to allow traffic from 192.168.9.0 to cross the ASA boundry you should also include a static route on the ASA to direct 192.168.9.x IP back to 192.168.20.3
When adding static routes they have to be added on all location.
i.e.
192.168.9.0 =>192.168.20.3=>ASA
ASA => 192.168.20.3 => 192.168.9.x

You likely have the issue that the traffic from the 192.168.9.x leaves and gets to the destination, but the response dies at the ASA since it does not have any information on how or where to route a packet with the destination of 192.168.9.x.
0
 
arnoldCommented:
Debug your setup looking for packets originating/destined to 192.168.9.x this will show which is the issue. I.e. if you do not have packets on the ASA that originate from 192.168.9.x you would need to check the 192.168.20.3 to see whether it is NATing the VPN traffic.  in this case, the 192.168.20.3 is at issue in terms of when the response packet makes its way back, the 192.168.20.3 is not senging it through the  VPN.
If you see on the ASA traffic from 192.168.9.x and then see responses that are dropped, this will be fixed by adding a static route on the ASA to direct any packet destined to 192.168.9.x to the 192.168.20.3.  You may need to add an ACL to allow this traffic to pass.
0

Featured Post

Identify and Prevent Potential Cyber-threats

Become the white hat who helps safeguard our interconnected world. Transform your career future by earning your MS in Cybersecurity. WGU’s MSCSIA degree program was designed in collaboration with national intelligence organizations and IT industry leaders.

  • 7
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now