Solved

kbmMemTable missing DSDesign.dcu

Posted on 2010-03-23
5
1,276 Views
Last Modified: 2013-11-23
Is anyone using kbmMemTable with C++ Builder/2010?  I bought the subscription so that I could get the 6.0 sources, but the newest C++ project they have is for BCB6 and it doesn't work.  The developer recommended using the D2010 project, but that requires Delphi, which I do not have.

The code references DSDesign.dcu, which it can't find.  I found sources for it, but including those in my project just leads to more undefined symbols that I cannot find.

I'm dead in the water until I get this resolved.  Does anyone have any hints for me?

Edit:  Does anyone know if there are libraries/units included with Delphi that are not installed with C++ Builder?  Is it possible that this is my problem, or am I barking up the wrong tree?  I actually have similar issues with another major component we're using, but it's a little less mission critical.

Any hints or tips will be greatly appreciated.  Thanks!!
0
Comment
Question by:kmustang1
  • 3
  • 2
5 Comments
 
LVL 9

Expert Comment

by:Mahdi78
ID: 28603568
Add vcldesigner.dcp to requires of package
C:\Program Files\CodeGear\RAD Studio\6.0\lib
0
 

Author Comment

by:kmustang1
ID: 29131698
Thanks Mahdi78.  Unfortunately, this is C++ Builder.  I cannot add Pascal units to the requires sections. Those units need to be compiled into a library in order for me to use them (as far as I've been able to tell, anyway).  This is the bit that I'm missing, I haven't been able to find a library that includes that package.

Someone on the kbmMemTable forums suggested using the command line tools to do the compile.  This sort-of worked, the compile seemed to succeed, but I cannot load the resulting package into the IDE.

Thanks for your suggestion!
0
 

Author Comment

by:kmustang1
ID: 29133006
Update:

I found the vcldesigner.bpi, and tried to add that to my requires section.  It errors and tells me that it is already in the search path.
0
 
LVL 9

Expert Comment

by:Mahdi78
ID: 29143143
Try designide.dcp, dcldb.dcp or VclSmp.dcp, try other dcp files in lib directory
0
 

Accepted Solution

by:
kmustang1 earned 0 total points
ID: 32305908
I can not link in any .dcp file.  Thanks for your help, though!
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A lot of questions regard threads in Delphi.   One of the more specific questions is how to show progress of the thread.   Updating a progressbar from inside a thread is a mistake. A solution to this would be to send a synchronized message to the…
Creating an auto free TStringList The TStringList is a basic and frequently used object in Delphi. On many occasions, you may want to create a temporary list, process some items in the list and be done with the list. In such cases, you have to…
This tutorial covers a step-by-step guide to install VisualVM launcher in eclipse.
The viewer will learn how to use and create new code templates in NetBeans IDE 8.0 for Windows.

713 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question