[Webinar] Streamline your web hosting managementRegister Today

x
?
Solved

Exchange 2007 SMTP Domains

Posted on 2010-03-23
12
Medium Priority
?
1,323 Views
Last Modified: 2012-08-14
I"m setting up a test organization with Exchange 2007.  The domain name inside is divind.internal and the public domain is divind.com.  I can connect to the Exchange server with Outlook 2007 no problem and send to anyone else using a divind.internal address.  When I try to send an email out to the Internet, I get the following error:

Microsoft Exchange couldn't deliver the message to this recipient because it didn't recognize you as a valid sender. Please verify that you have the correct sending address configured in your e-mail client and try sending your message again, or provide the following diagnostic text to your system administrator

The following organization rejected your message: imta20.emeryville.ca.mail.comcast.net.

Now, I know that .internal is not routable over the Internet and .com is.  How can I get this annoying error to go away?
0
Comment
Question by:sedberg1
  • 6
  • 5
12 Comments
 
LVL 20

Expert Comment

by:Rick Fee
ID: 28380456
Have you setup divind.com as an accepted domain?  


0
 
LVL 7

Expert Comment

by:supports
ID: 28380459
I guess u can change the SMTP to gmail if u have a gmail account and authorize your gmail account to send out emails
0
 
LVL 20

Expert Comment

by:Rick Fee
ID: 28380607
Exchange Management Console -->  Org Config --> Hub Transport -->  Accepted Domains tab...


0
Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

 

Author Comment

by:sedberg1
ID: 28380703
EndureKona,

I went into organization Configuration > Hub Transport > Accepted Domains > New Accepted Domain and did add that domain.  Divind.com is the domain that users outside my organization would send to while divind.internal is the name of my domain inside the LAN.  

The problem happens when I send to an outside address like Comcast.

0
 

Author Comment

by:sedberg1
ID: 28380784
You know what I just noticed, I sent to a Gmail account and didn't get the error.  Is there something wrong with my DNS records for divind.com?  
0
 
LVL 20

Accepted Solution

by:
Rick Fee earned 2000 total points
ID: 28381120
If your sending out email you want to ensure your have MX records and PTR records porperly setup.   Did you just setup this divind.com accepted domain?   If clock on the Email Address Policies (Exchange Management Console -->  Org Config --> Hub Transport -->  email address policies)  
And add divind.com and set as the primary and make sure it changes all the mailboxes to use divind.com as the primary.   My guess is still when you send its going out as users@divind.local  you want this to be set as com.
0
 

Author Comment

by:sedberg1
ID: 28381338
I have an accepted domain for both divind.internal and divind.com.  They are both authoritative.  I did nothing in Email Address Policies but there appears a Default Policy in this list with the lowest priority.  Under Applied, the Default Policy says False.  How would I change the primary to divind.com for all mailboxes?
0
 
LVL 20

Assisted Solution

by:Rick Fee
Rick Fee earned 2000 total points
ID: 28381838
Edit the Default Policy under Email Address Policies...the Email Addresses section click Add...select Select accpeted domain for email address click Browse select divind.com...then select Set as Reply...set the schedule to run immeditaely...once done right click on Default Policy and select Apply.
0
 

Author Comment

by:sedberg1
ID: 28382622
Ok, I did that. The emails go out and I don't get an error back from the Exchange server.  However, the emails didn't show up in the destination's inbox.  Tried sending to an external .net, .com, and Gmail account.  Before, the emails were at least going to the Gmail account.  Now they don't.  They're not in the Queue, I checked.
0
 

Author Comment

by:sedberg1
ID: 28382926
Ok, I put something in wrong in the Email Address Policy.  When I added divind.com, there was a %m in front of it.  I edited the divind.com and unchecked the box for Email address local part, and the problem went away.  Can now send/receive externally no problem!  

Thanks for your help!  This Exchange stuff is not so easy.  I'm reading an MS Press book on how to do this, and it's tough.  The examples they give you, I try to apply to my real domain in a test VM.  Not very simple with all the connectors, policies, shell, folders, etc.
0
 
LVL 20

Expert Comment

by:Rick Fee
ID: 28385810
cool glad the issue is resolved...good deal about the book that's the same way I pick this stuff up
0
 

Author Comment

by:sedberg1
ID: 28581784
If anyone's interested about the book, the one I got was VERY helpful in learning Exchange 2007.  In fact, I feel like I can tackle a full Exchange environment now.  The book is a MS Press book titled Configuring Microsoft Exchange Server 2007, ISBN: 978-0-7356-2410-8
0

Featured Post

Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

You finally migrated Public Folders to Office 365, decommissioned the Public Folder mailbox database and since then, when you send an email from on-premise to mail-enabled Public Folders, you get the following error: "Misconfigured public folder mai…
Exchange administrators are always vigilant about Exchange crashes and disasters that are possible any time. It is quite essential to identify the symptoms of a possible Exchange issue and be prepared with a proper recovery plan. There are multiple…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
This video shows how to quickly and easily deploy an email signature for all users in Office 365 and prevent it from being added to replies and forwards. (the resulting signature is applied on the server level in Exchange Online) The email signat…
Suggested Courses
Course of the Month11 days, 2 hours left to enroll

612 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question