• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 609
  • Last Modified:

IMAP Port Issue - Server 2008/Exchange 07 Netgear FVX538

I have an aggrivating problem which is I am hoping is something simple..
I have Exchange 2007 on Server 2008. My firewall is Netgear FVX538 and we are running TrendMicro IWSS and Scanmail on the network.

I know that I have IMAP set up properly on the server because I can telnet into it and pull the inbox, etc. using command prompt with no problems.

However, I cannot get it to work offsite. I am sure this is pointing to my firewall, but I cannot figure out why it will not work. I get a connection refused message when trying to use canyouseeme.org port checker.

I cannot figure out what the problem is. I have tried to check my firewall logs and I do not see anything in there for port 143 (dropped or allowed). We are on business class internet service with Cox and there are no ports blocked.

I have the port configured exactly the same way that I have SMTP and POP3 set up (those work). Which is the following:

In the Netgear, I have a custom service setup that starts and ends on port 143 (TCP).

Then in the Inbound rules, I have a rule set up that is set for the aforementioned service, ALLOW always, Send to LAN server x.x.x.21 which is my Exchange server, translate to port 143, WAN Destination IP address: WAN1 (which is where this server is located), LAN users: ANY, WAN Users: ANY, LOG Always:

Am I missing something simple here? Thanks!
  • 2
2 Solutions
Are you trying to use security such as TLS/SSL on port 443 or 993 from outside but do not have those ports forwarded?
acs-mikeAuthor Commented:
Not that I know of. I am not too familiar with IMAP, but doesn't it use Port 143? I understand that with Exchange 2007 it uses SSL login by default, but I have disabled that to only use plaintext login. Either way, I need to not have to use SSL because I do not think that BB BIS supports that. Could this be what is causing my problem? I don't think that it is though because I am thinking I am getting blocked before I even get to the server. I have successfully telnetted into IMAP on 143 locally so it shouldn't be the firewall on the server. I have double-checked to ensure that port is open as well.


acs-mikeAuthor Commented:
FINALLY! I figured it out and it was something so simple and so random that it finally hit me! The port forwards are all set up in a hierarchy. Well, IMAP was listed at the bottom - I thought that was the only thing that I had not tried and therefore moved it up above HTTP and now it works!! Thanks for the help everyone.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now