Help with Team Foundation Server 2008 WorkGroup Edition

I have just set up Team Foundation Server 2008 WorkGroup Edition in a single server configuration. I created a project and added 5 users to the project. Each user is able to connect to TFS and see the project I created without issue. However, no one (even me, the site administrator) seems to have access to "Add Files" to the project. The "Add Files" toolbar button is greyed out and "Add Files" is not available from the context menu on either the project or server in Source control. "Check in pending changes" is there, just not add. I am a member of the "Project Administrators" group, "Team Foundation Valid Users" group, "Team Foundation Administrators" group and the "Team Foundation Licensed Users" group.

Any help would be appreciated.
51685086MKAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mohamed OsamaSenior IT ConsultantCommented:
It appears you still miss  some permissions on the source control level that are not being inherited, I would suggest giving a go to TFS administration tool from codeplex
http://www.codeplex.com/TFSAdmin
0
Mohamed OsamaSenior IT ConsultantCommented:
the same can also be achieved by our TFS admin from command line (visual studio command prompt ), using the TF permission command 
http://msdn.microsoft.com/en-us/library/0dsd05ft(VS.80).aspx
0
51685086MKAuthor Commented:
I used the codeplex tool to set up the permissions accross sharepoint, SSRS and TFS. Could you please be more specific what I may have missed?
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

Mohamed OsamaSenior IT ConsultantCommented:
Ok , here is the easiest way to do it .
Get Team Foundation sidekicks 
install , run , open Permissions sidekicks , Navigate to your project , select the user or group in question from drop down menu , make sure users have the permissions as per screenshot



TFS-SC-Perm.JPG
0
51685086MKAuthor Commented:
I installed the program from the link. However, I don't see the tool available within Visual Studio. Also, the stand-alone application doesn't allow me to sign in using a domain which I need for TFS.
0
Mohamed OsamaSenior IT ConsultantCommented:
Not available from Tools>team Foundation sidekicks>Permissions sidekciks ?
as for the standalone , you should uncheck use current credentials , and type your login without the domain , this is not needed if you are already logged in to this domain / workgroup.
0
51685086MKAuthor Commented:
OK, I finally figured it out. I needed to install Visual Studio 2008 SP1 locally for it to actually work.

Thanks for your suggestions anyway. The Sidekicks tools look pretty cool.
0
Mohamed OsamaSenior IT ConsultantCommented:
You are welcome , the sidekicks tool is indispensable for TFS admins, project leads and code reviewers.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
.NET Programming

From novice to tech pro — start learning today.