ActiveX component can’t create object Error (Com Class / VBA)


I have created a Class Library project.  To this I have added a Com Class Item.  Within this I have added a few simple functions.

I then compile this as Release and I get a DLL and a tlb file.

I then reference these with Access 2003 VBA and then create an object of class and therefore have access to .net functions within a VB6 environment.

This works perfectly on my primary machine.

I now need it to work on my laptop.  I assumed that if I copied the tlb file across and then added a reference in the same way as above all would be well.  Unfortunately it does not work. Instead I get the following error:

Run-Time error ‘429’:
ActiveX component can’t create object

Does the laptop need Visual Studio in order for this to work?  Any suggestions as to how I can get this to work appreciated.

(I’ve tried copying the entire contents of the  bin\Release folder but this does not work either)
Who is Participating?
EricBrackeConnect With a Mentor Commented:
I've done this several times.
Best option is to create an installation package:
Open the solution in VS
Goto File | Add | New Project
In the "add new project" window:
Select Other Project Types | Setup and Deployment
Select "Setup wizzard" in the templates list
Follow the wizzard to create the installation project
Once your installation wizzard finished, compile the setup project.
In the output folder you will find the installation files
use these to install on your other machines.
You need to register the COM object

Use following at command line

Regsvr32 pathandnameofdll
You will need the .NET framework and you will have to register the class using regasm.exe you don't have this problem on the development machine because you might have the option "Register for COM interop" checked which does all the registration when you build.
Assembly Registration Tool (Regasm.exe)
Never miss a deadline with

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

andyw27Author Commented:
Tried the Regsvr32 D:\Release\Class_MD5.dll command but got an error of:

...dll was loaded but the entry-point DllRegisterServer was not found.
Do you have .NET framework installed?
andyw27Author Commented:
andyw27Author Commented:

Many thanks for your comments.  It worked like a dream and saved me many hours in trying to figure out the particulars of why this was not working.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.