Server 2008 R2 ICS on MSLOOPBACK for hyper-v VM's

I cannot get the ICS service to start.  All the dependent services are started, so that rules out dependency issues.  When I'm in a hotel, I only get 1 IP address, so using ICS is the only way i can get internet to the VM's.  I do this by ICS sharing my wired nic to the loopback or ICS sharing my wireless to the loopback.  This used to work with server 2003 and virtual server 2005.  Now that i need 64bit virtualizing platform i'm forced to go this route, but getting over this ICS hurdle is a pain.   Any suggestions would be great.
WisconsinLutheranCollegeAsked:
Who is Participating?
 
WisconsinLutheranCollegeConnect With a Mentor Author Commented:
First I had to add in the legacy hardware for the loopback adapter.  Then add the wireless support feature.  Start the wireless autoconfig service.  Now that your wireless adapter is working along with the wired, go to the manage network adapters page of the network and sharing center.  Hold ctrl and click the wired nic and the wireless nic.  Right click and chhose bridge.  Now add the hyper-v role and the network access policy role.  A sub network access policy role will pop up and choose the 2nd + from the top and it's 2 sub components.  When thats done you will have to reboot.  Now open the hyper-v manager.  Create a new network adapter in hyper-v with the external option.  Choose the mslooback adapter as the external nic that hyper-v will talk to.  Now go to manage network adapters again in the sharing center and give the new hyper-v network card an IPv4 IP address such as 192.168.9.1.  Now open up the server manager and fine the network access section of the roles and there will be 1 item with a red square icon. Use the wizard to setup a new NAT.  Choose the bridge for the internet nic.  Choose the hyper-v created external nic as the one to NAT with.  Choose the top option for name resolution and DHCP and click finish.  Once the RRAS service has been started you can go to the hyper-v manager and start up a VM.  When your VM starts, it should get a 192.168.9.xxx address and should be on the internet.
0
 
WisconsinLutheranCollegeAuthor Commented:
That was the first thing i tried.  I originally wanted to share my wireless adapter with the MS LOOPBACK adapter and set all my VM's to use the loopback adapter.  Server 2008 R2 apparently doesnt like to let you use ICS.  What I ended up using instead of ICS is RRAS.  I'll post again with the actual solution.  What tipped me off to the solution was this link which i found about 2hrs after posting this question. http://technet.microsoft.com/en-us/windowsserver/dd430329.aspx
0
 
msmamjiCommented:
Great. Looking forward to your post.
0
All Courses

From novice to tech pro — start learning today.