Images are printed black from Citrix sessions

We are having problems with images printed black from our Citrix servers.

This is the case. I have User01 which is using Printer01, when he prints some job, which contains any image, this image in printed as a black cube. When he prints the same document on Printer02, its printing normal. Printer01 & Printer02 are fullly equal. They are using the same driver and have the same options. Even the config of both of the printers are fully equal.

It doesnt matter which published application i use or which server im connected to.

Only difference between the 2, both are added onto the Citrix servers at the same time, but Printer01 wasn't used before.

Could anyone help me out?

PonLogistiekAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

KrAzYCommented:
Are you using the Universal Printer Driver, the Citrix Printer Drivers, a native driver, or an installed driver?
0
PonLogistiekAuthor Commented:
Well it seems that the UPD is used. Printing from local workstations using the printerdriver works fine. Do i need to map a driver or?
0
PonLogistiekAuthor Commented:
You got any more suggestion?
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

KrAzYCommented:
So these are network mapped printers and not printers the client sees?
What version of XenApp and what version of the client are you using?
0
PonLogistiekAuthor Commented:
These are network mapped drivers indeed. We are using PS 4.5 Rollup Pack 5 on Windows 2003 x64. We are using XP (embedded) clients.
0
PonLogistiekAuthor Commented:
Anyways it seems the UPD is being used at our Ricoh printers. I want to the Ricoh driver to print, but how can i manage this? Making a print mapping? My printer policies are:

Auto Creation Enabled, Auto create all client printers
Native rpinter driver enabled, install windows native drivers as needed
Universal driver enabled, Use only pirnte rmodel specific drivers

The Driver compatibility is set @ Allow all drivers except those in the list

The native drivers are all added, but i discluded the CItrix Universal printer driver and the HP driver (CTX UPD also)

Any more suggestions?
0
KrAzYCommented:
Hmm... what client are the end users using or the one with an issue?
Not sure if I follow your first point.  Is it the UPD or the CUP?  It depends on client version.  Some people may use different terminoligy, but the UPD was a set of 3 PCL drivers I believe that were used with older version of XenApp and/or older version of the client.  Now with your version of XenApp and a newer client (I believer 9.x or higher) user the CUP (Citrix Universal Printer) which is a RAW print job and we've had a lot of success with.
I'm confused about you not wanting the UPD (or the CUP) and using the Ricoh drivers.  If it works for one (UPD/CUP), then why not continue that?   Does that printer have a native driver in W2K3?  Have you installed that printer driver on the servers (try and avoid, but sometimes necessary)?
0
cfowlerlock77Commented:
Hi there,

Have you tried changing your drivers to be postscript or using the PCL mini driver?

Cam
Ricoh Software Analyst
0
PonLogistiekAuthor Commented:
I tried to use the PS driver and PCL mini driver. Both dont give me the output i sent to the printer. I deleted the drivers for the Ricoh printer and reinstalled them. Didnt work.

@Krazy: We are using the Ricoh drivers, but this seems to conflict with Citrix. I was a little confused about which driver we were using. But accessing the printer in our session, shows the "ricoh config" when u modify printer preferences.

Strange is, that when i print from the CTX server itself (console) it prints normally.
0
PonLogistiekAuthor Commented:
We are currently running a test on w2k8 and until now no problems
0
PonLogistiekAuthor Commented:
Looks like citrix/powerfuse and wk3 don't work that well together...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
PonLogistiekAuthor Commented:
sorry i hit the submit button..  ........ with ricoh printer drivers
0
PonLogistiekAuthor Commented:
As the Comment By: cfowlerlock77 gave us a direction. But we found the workaround/solution
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Citrix

From novice to tech pro — start learning today.