Receive as Access on all Mailboxes for the Administrator Account

Guys,

This is turning out to be a rediculoius issue. All I want to do is set Receive As access on all Mailboxes (6 in total) using the command line tools and I've wasted about half a day.

The exact commant I am using is:

Add-ADPermission -Identity "D:\Program Files\Microsoft\Exchange Server\Mailbox\First Storage Group\Mailbox Database.edb" -User "PHOENIX\Administrator" -ExtendedRights Receive-As

Can someone please tell me where the error is at Line 1 Char 17, as this is becoming a joke.

Kindest Regards
Scott
SCOTTITAsked:
Who is Participating?
 
Justin DurrantConnect With a Mentor Sr. Engineer - Windows Server/VirtualizationCommented:
looks like you already resolved
0
 
SCOTTITAuthor Commented:
Please ingnore, I've found it ....

Add-ADPermission -Identity "Mailbox Database" -User "PHOENIX\Administrator" -ExtendedRights Receive-As

**!!*( £*£**$*%$**%*%

0
 
Justin DurrantSr. Engineer - Windows Server/VirtualizationCommented:
The identity needs to be the mailbox name not the full path
0
Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

 
SCOTTITAuthor Commented:
OK
0
 
SCOTTITAuthor Commented:
OK
0
 
SCOTTITAuthor Commented:
Please Close this question
0
All Courses

From novice to tech pro — start learning today.