Corrupted Exchange databases and storage

I'm managing an Exchange 2007 organization, on a CCR cluster. Last week we had a failover and could't update CCR on other node as three databases were corrupted (at least this information was received after we run backup with verification). we decided to create new database, move mailboxes to that new database, deleted the corrupted ones, recreate again, move mailboxes back. All went ok until backup with verification was started again and same three databases appeared corrupted.
Seems to me clear that there is a problem on storage (something wrong with the LUNs) as there is too much coincidence, but when asking the storage admins they say that no errors appear from their side.

What aproach can I chose ?
Have you experienced something similar ?

If aditional info is required, please ask.

Thanks in advance.
LVL 12
florin_sAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

cornetthdCommented:
I ran across the same issue.  After creating new databases and moving mailboxes the problem was still there.  To correct the problem we had to delete the database on the inactive node and reseed the databases to clear the error.
0
florin_sAuthor Commented:
This was already performed.
New database was created, old databases from both active and passive nodes were deleted (logs also), recreate the databases and move mailboxes back...backup without verification is ok, while when running backup with verification following errors appears:

"Operation terminated with error -1206 (JET_errDatabaseCorrupted, Non database file or corrupted db) after 2167.540 seconds.

ERROR: page 7727973 checksum failed ( 0x77537753b67abcd8 / 0x1956e6a9afdc8f5f )"

Could this be maybe related to SnapManager for Exchange application maybe, and not to storage...
0
cornetthdCommented:
Just to make sure I would run eseutil /g against the database.  This is an integrity check to look for corruption.  No changes will be made to the database.
0
florin_sAuthor Commented:
Database is ~110 GB...so it would take a lot of time :(.
Our next step I think will be creating new database, move mailboxes to that new database, deleted the corrupted ones, [b]delete the LUNs also[/b], recreate again, move mailboxes back.
0
florin_sAuthor Commented:
Problem looks solved...solution was moving db with error, deleting the LUNs and old databases, recreating LUNs and databases, moving mailboxes back.

So far so good...

/closed
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.