• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 703
  • Last Modified:

RDP Desktop Background in SBS2003

I spend alot my my day using RDP into various servers. I want to change the background so that I can create backgrounds with the names of the server I am currently working on. However, no matter which machine I hook into the option to browse for new or select existing backgrounds is greyed out. I have specified in the advanced properties of RDP that I want to see the Desktop background for the connection but still it is greyed out.

Can anyone help me on this please???
0
NorthstarIT
Asked:
NorthstarIT
  • 3
  • 2
1 Solution
 
storkyIVCommented:
Have you tried connecting from the start>run box?

mstsc /console

This usually connects you with full resource.
0
 
NorthstarITAuthor Commented:
Yes I have and everything is still greyed out
0
 
NorthstarITAuthor Commented:
If it makes a difference when I use the same RDP config to attach to an SBS2008 server it is fine. It is only SBS2003 that is causing me the grief
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
storkyIVCommented:
I have found this - this is probably what you are after.

By default Windows 2003 servers (WHS is based on W2K3) don't display the background desktop wallpaper in a client TS session, ie. Remote Desktop. You can change that behavior, according to the help description, by running gpedit.msc on the WHS and changing the Local Computer Policy | Computer Configuration | Administrative Templates | Windows Components | Terminal Services | Enforce Removal of Remote Desktop Wallpaper group policy. Here is the guidance for that policy.

Specifies whether desktop wallpaper is displayed to remote clients connecting via Terminal Services.

You can use this setting to enforce the removal of wallpaper during a remote session. By default, Windows XP Professional displays wallpaper to remote clients connecting through Remote Desktop, depending on the client configuration (see the Experience tab in the Remote Desktop Connection options for more information). Servers running Windows Server 2003 do not display wallpaper by default to remote sessions.

If the status is set to Enabled, wallpaper never appears to a Terminal Services client.

If the status is set to Disabled, wallpaper might appear to a Terminal Services client, depending on the client configuration.

If the status is set to Not Configured, the default behavior applies.

You then need to configure the client to display desktop wallpaper when you open the Remote Desktop connectoid and select the Options | Experience tab. See above.
0
 
Richard DanekeTrainerCommented:
Your RDP desktop provides a username unique desktop.  Instead of setting a background, it would require fewer resources (less bandwidth) to place a text file on each desktop to identify the server.  Plus, some user specific data can be stored in there as well.
0
 
NorthstarITAuthor Commented:
Exactly what I needed. Thank You!!!
0

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now