Prevent Exchange Cached mode from being configurable on a Win 7 hm stand alone PC w/outlook 2007

I have new locked down laptops with windows 7 hm edition and office 2007 loaded.  While in the office - the machines will map network drives w/authentication and allow email to Outlook from Exchange 2003.  Laptops do not authentice to the domain - only when mapping drives do they authenticate so GP is not an option and it is HM edition so local GP is also not an option.  I want to use the registry to disable the Use Cached Exchange Mode button so the individual user cannot configure it.  I want it so that if the laptop is not working locally - they will NOT be able to use oulook from the laptop and so no data will store on the laptop.  If users are outside of the office they can access via Citrix or OWA.  
How can I configure the registry of HKCU to turn off this option?
jenitAsked:
Who is Participating?
 
cornetthdConnect With a Mentor Commented:
I found this within Experts-Exchange

http://www.experts-exchange.com/Software/Office_Productivity/Groupware/Outlook/Q_21318508.html

traval:Could be a corrupt profile, but before creating a new one check the HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Outlook\OST key first.  If there is a NoOST value that is set to 2 change it to 0.

0 - An offline store is set up by default and used for calendar caching. Also, the user is allowed to enable offline access and use the offline store. This is the same as the absence of the OST key and NoOST value.

1 - An offline store is set up by default and used for calendar caching. However, the user is not allowed to enable offline access and use the offline store. The options in the Microsoft Exchange Server properties are not available.

2 - An offline store is not set up by default and the user is not allowed to enable offline access and use the offline store. The options in the Microsoft Exchange Server properties are not available.

3 - An offline store is not set up by default and the user is allowed to enable offline access and use the offline store.

Accepted Solution
0
 
jenitAuthor Commented:
Addl info.  It needs to be disabled so that the user cannot change it on their own at a later time.
0
 
cornetthdCommented:
Try this:

HKCU\Software\Microsoft\Office\12.0\Outlook\OST\NoOST = 3 (hex)
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
jenitAuthor Commented:
That did not work.  I had to add the...Outlook\OST keys in the correct location under 12.0 and it did not work.  Even rebooted to ensure the entry applied.  I can still see and make changes to the Use Cached Exchange Mode box in the exchange setting tab.  Any other thoughts???
0
 
cornetthdCommented:
I found this witih this website.  Not sure if this will work or not.

amaheshwari:It can be disabled through Registry as well

Go to Start->Run->Regedit

Cached Exchange Mode is controlled by the following key;
[HKey_Current_User\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\<ProfileName>\13dbb0c8aa05101a9bb000aa002fc45a]

00036601     (REG_BINARY)

enabled value;  84 01 00 00
enabled with Public Folders/Favorites: 84 05 00 00
disabled value; 04 00 00 00

Please check.
Note:Please note that the "00036601" registry key stores more connection settings that just wether or not Cached Exchange Mode is enabled. The values above are taken from a new mail profile with only the Cached Exchange Mode setting changed. If you're going to deploy this registry key I recommend taking the value from a properly configured machine for your environment.
Accepted Solution
0
 
jenitAuthor Commented:
That will turn it off, but it does not make it so the user can't turn it back on themselves.  I did try that one yesterday :-).  Thanks for your efforts.  It's out there somewhere - there just isn't a lot of documentation about the registry for win 7 yet.  There is alot out about using GP to lock it...but that won't work for my situation.  I'll keep looking.  
0
 
jenitAuthor Commented:
I have to be at another site today so I may not get to try this until Monday.  Sounds possible.  I'll let you know.  Thanks for your help.
0
 
jenitAuthor Commented:
That was the trick.  Although I did not have a corrupt profile...adding the setting BEFORE I created the outlook profile did the trick.  Awesome.  Thanks for your help. It works perfect.  If the network cable is disconnected - the outlook session is not available and they have NO way to change to cached mode as the option is grayed out.  YEA!!!!  This will make all feel better about letting them use programs locally vs thru citrix only.  Thanks and have a good day!
0
All Courses

From novice to tech pro — start learning today.