Exchange 207 Can't deliver Mails to Yahoo larger than 2MB

Hello Every Body
I'm Experiencing problems with exchange 2007 standard
It fails to send emails to yahoo that is larger than 2MB or it take a lot off time after many failed attempts (with error code 421 4.2.2.2 Connection Dropped)
when I send to hotmail, gmail the message are sent straight forward
also the the mail server is connected directly to the internet through its public IP
and I have Symantec EndPoint installed on the server and symantec mail security for exchange
So can anyone help me with this?

Thanks
mary_87Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Alan HardistyCo-OwnerCommented:
Are you able to email other domains with attachments larger than 2mb without a problem?

If yes, is your server up-to-date with patches and Service Packs?

What router do you have and is it on the latest firmware version?
0
mary_87Author Commented:
Yes I don't have problems with the other domains

The server is connected Directly to the cisco router and then satellite receiver
and there is alot of users that using their laptops and the connect to yahoo mail via web-based and pop3 and sending larger than 2MB

0
Alan HardistyCo-OwnerCommented:
Have you got SMTP fixup enabled on the router?

If you have, please disable it and try sending again.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

mary_87Author Commented:
no
0
mary_87Author Commented:
does yahoo server is slower than gmail and hotmail or it need a better connection?
0
Alan HardistyCo-OwnerCommented:
Not that I am aware of.  It could be a software / firmware issue on your Cisco box.  Is it up-to-date.
0
mary_87Author Commented:
I don't now since its restricted to the provider and I don't have access to it
0
Alan HardistyCo-OwnerCommented:
Worth making a phone call to check I think.  Just to rule it out as a potential problem.
0
mary_87Author Commented:
are you sure the problem  is not from yahoo ?
0
Alan HardistyCo-OwnerCommented:
I would imagine that it is not if it is just you.  I'll send myself a 4Mb file to my yahoo account and see what happens.
Watch this space.
0
Alan HardistyCo-OwnerCommented:
5Mb file arrived just fine.
0
mary_87Author Commented:
I don't think it is from the router beacuse I have many yahoo users that use pop3 client and they send and receive emails without problems
0
Alan HardistyCo-OwnerCommented:
It would be nice to rule it out though.

Are you sending mail via a smarthost or direct?

If via a smarthost, please see this previous EE question:

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_24280201.html

It could also be Endpoint / Symantec Mail Security.  I had no end of problems with SMSMSE and ditched it in favour of Vamsodt ORF (www.vamsoft.com).

Only way to test is to remove the software!!!
0
mary_87Author Commented:
no i can't remove it and i use it dirctly without smart hosts
0
Alan HardistyCo-OwnerCommented:
I'll ask another EE Exchange Genius for their thoughts, but I would expect they may say the same as my last comment.
0
Glen KnightCommented:
Interesting one.

Antivirus/SPAM is normally the first place I would start for this sort of thing but if it is only happening when sending to Yahoo! that is a bit odd.

You can disable the transport Antivirus Scanning by locating the registry key:
HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\TransportAVAPI and edit the value called Enabled setting the value to 0.  If the value is 1 then it is enabled 0 is disabled.

Once you have made this change I would restart the exchange server.

The other thing to check is from your exchange server telnet to each of the Yahoo! SMTP servers on port 25 and type: ehlo yourdomain.com (replace yourdomain.com with your real email domain)

this will provide you with some ESMTP values and one of them should be the maximum size allowed.

The yahoo SMTP servers are:

a.mx.mail.yahoo.com
b.mx.mail.yahoo.com
c.mx.mail.yahoo.com
d.mx.mail.yahoo.com
e.mx.mail.yahoo.com
f.mx.mail.yahoo.com
g.mx.mail.yahoo.com
h.mx.mail.yahoo.com

if the results are the same on each could you post one of the outputs.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mary_87Author Commented:
sir i have only this problem with yahoo
and large attaches can be send but it take a lot lot lot time so what is the probleem??
0
Alan HardistyCo-OwnerCommented:
Have you run the tests Demazter has outlined above?  If so, what are the results?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.