• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1175
  • Last Modified:

Read-Only check mark keeps coming back even after attrib command

This is a toughy.  I had a user mess up her folder permission by chaning the owner of the folder.  I corrected the owner by putting the local madhine\administrators, but she is having an issue where everything in the C drive is read-only and the check box mark keeps coming back even when unchecked.  I saw a post about the attrib command, but that did not work.  Another weird thing is that even I see that the user has security permission, when I try to copy that file, it stated "access denied".  Any suggestions?
  • 2
1 Solution
B HCommented:
is the checkmark solid, or kind of greyed out (or if xp home, a green square instead of a checkmark)?

if that's the case, and if you're talking about a folder - xp does that... it doesnt mean it's read only... you can remove the check/square all day long even forcing it down to the child folders - it will always be there.  started with an update a few months ago.

now, access denied - is it for the direct thing you're trying to copy, or is it after a few seconds, when it gets deep into the child folders?

you might make sure you set the permissions you want, at the highest level folder, then go into 'advanced' and put a checkmark for it to overwrite all the child folders with those you just specified.  failing to do this will let the child folders inherit the ones you just set, but if a deep folder has chosen to "DONT inherit from the parent objects", then you're not actually setting them that deep.

please confirm if you mean "file" or "files" or "FOLDER" and check into my comments above
esi_se_parkAuthor Commented:
- The check mark is actually sold green square.

- As for the access denied, I force the permission down from the top by putting a "checkmark" for it to overwrite all child folders.  I checked to see if the permission did spread down and they do.  I even tried changing the permission on this particular file exclusively.  It says that I have "full" permission, but I cannot copy this file or any file in this folder.  So it's "files".  It's all excel file if there is a relevence.  To add to it, they are all green in text, so they are encrypted.  I can't uncheck the "encrypt" attribute.  It also gives me "access denied".
B HCommented:
oh - encryption is a little different yes...  it might be easiest to find out what user account encrypted them, and tell it to decrypt them.

you might take a look in security > advanced, and see if there are any DENY entries.  no matter what, DENY entries will always overrule ALLOW entries
You Cannot View or Change the Read-Only or System Attribute of Folders

Guessing you read this one, since you mentioned the Attrib command, but it explains that Windows typically ignores the RO attribute.

"it might be easiest to find out what user account encrypted them, and tell it to decrypt them."

Think thats the best track, as it is most likley not a RO Attribute problem at this point.....
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now