Dual DNS records for Windows 2003 SBS server

Recently I have found that my SBS DNS is registering 2 A records for the PDC, one for each interface where as previously it was only registering the internal interface.

I have checked the adapters advanced properties and the option to have the record registered with the DNS is disabled for the adapter I don't want in the DNS. I have deleted the record but it just simply reappears after a while so something is putting it back in there.
LVL 2
SectorX4Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MrN1c3Commented:
Open the Local Area Connection properties

select tcpip, and then properties
select advanced
select the dns tab
uncheck "register this connections addressin DNS"


0
SectorX4Author Commented:
As I said in my initial post I have already done this.
0
Amit BhatnagarTechnology Consultant - SecurityCommented:
This is a common issue and cannot be resolved by unchecking the Option in TCP\IP properties. What you need to do is to tell the DNS Server to only publish the desired IP in DNS. You can achieve this by creating a Registry Key as per this article :
http://support.microsoft.com/kb/246804 
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DNS\Parameters\PublishAddresses
Frankly, I am surprised how your DNS Server was NOT registering both the IPs initially. Unless, you make the changes in the registry, the DNS Server will ALWAYS register all the IPs available with the local machine.
P.S : Make sure to delete the records manually after you have created this reg. key and restart the DNS Service. If done correctly, the Records will not re-appear.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SectorX4Author Commented:
Seems kind of strange that there would be an option for this that seems to be ignored.

I have changed the setting and it seems to be ok for now but previously it has done this so I'll keep an eye on it. Assuming it all goes well I think Bamit99 has found the problem
0
SectorX4Author Commented:
I have checked this setting again just now and everything is working fine, solution worked!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Active Directory

From novice to tech pro — start learning today.