winmgmt /salvagerepository Fails

I recently have the problem where Windows Defender turns itself off and I have to restart it on reboot. According the articles I read, it could be related the the WMI repository. When I try to run winmgmt /salvagerepository I get the following:


C:\Windows\system32>winmgmt /verifyrepository
WMI repository verification failed
Error code:     0x800700C1
Facility:       Win32
Description:    %1 is not a valid Win32 application

Where do I go from here?
esb91077Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

johnb6767Commented:
Repairing and re-registering the WMI
http://windowsxp.mvps.org/repairwmi.htm

Several methods that have always been a great resource for me in a WMI problem....
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.