VPN client not working on PIX 506E

I have a PIX set up as a hub for two other 506Es 6.3(5) . I also need users to log in with the Cisco software client (ver 5) and for some reason the IKE logs tell me that NEG FAILED using this config on the PIX. Can you see why ?  Only the hub is used for the software clients. Thanks for any help

David

: Saved
: Written by enable_15 at 20:39:48.385 EST Wed Mar 24 2010
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password /Jog8NmcYagxc6rp encrypted
passwd /Jog8NmcYagxc6rp encrypted
hostname Xerox2
domain-name ciscopix.com
clock timezone EST -5
clock summer-time EDT recurring
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list outside_in permit tcp any host 142.47.xx.xxx eq www
access-list outside_in permit tcp any host 142.47.xx.xxx eq https
access-list outside_in permit tcp any host 142.47.8.146 eq 3389
access-list SPLIT permit ip 192.168.15.0 255.255.255.0 any
access-list ra_crypto_acl permit icmp any 10.3.3.0 255.255.255.0
access-list no_nat permit ip any 10.3.3.0 255.255.255.0
access-list 102 permit ip 192.168.15.0 255.255.255.0 192.168.3.0 255.255.255.0
access-list outside-allow permit icmp any any unreachable
access-list outside-allow permit icmp any any time-exceeded
access-list outside-allow permit icmp any any echo-reply
access-list 101 permit ip 192.168.15.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list inside_nat0_outbound permit ip 192.168.15.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list inside_nat0_outbound permit ip 192.168.15.0 255.255.255.0 192.168.3.0 255.255.255.0
access-list inside_nat0_outbound permit ip any 10.3.3.0 255.255.255.0
pager lines 24
logging on
logging buffered warnings
mtu outside 1500
mtu inside 1500
ip address outside 142.47.xx.xxx 255.255.255.252
ip address inside 192.168.15.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool clientpool 10.3.3.1-10.3.3.6 mask 255.255.255.0
pdm location 192.168.15.200 255.255.255.255 inside
pdm location 10.3.3.0 255.255.255.0 outside
pdm location 192.168.2.0 255.255.255.0 outside
pdm location 192.168.3.0 255.255.255.0 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
global (inside) 2 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp 142.47.xx.xxx www 192.168.15.200 www netmask 255.255.255.255 0 0
static (inside,outside) tcp 142.47.xx.xxx https 192.168.15.200 https netmask 255.255.255.255 0 0
static (inside,outside) tcp 142.47.xx.xxx 3389 192.168.15.200 3389 netmask 255.255.255.255 0 0
access-group outside_in in interface outside
route outside 0.0.0.0 0.0.0.0 142.47.xx.xxx 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
aaa authentication ssh console LOCAL
http server enable
http 192.168.15.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ra_set esp-3des esp-sha-hmac
crypto ipsec transform-set example_set esp-3des esp-md5-hmac
crypto dynamic-map vpnclient_map 20 match address ra_crypto_acl
crypto dynamic-map vpnclient_map 20 set transform-set ra_set
crypto map example_map 10 ipsec-isakmp
crypto map example_map 10 match address 101
crypto map example_map 10 set peer 207.112.xxx.xxx
crypto map example_map 10 set peer 142.47.xx.xxx
crypto map example_map 10 set transform-set example_set
crypto map example_map 11 ipsec-isakmp
crypto map example_map 11 match address 102
crypto map example_map 11 set peer 142.47.xx.xxx
crypto map example_map 11 set transform-set example_set
crypto map example_map 20 ipsec-isakmp dynamic vpnclient_map
crypto map example_map interface outside
isakmp enable outside
isakmp key ******** address 142.47.xx.xxx netmask 255.255.255.255
isakmp key ******** address 207.112.xxx.xxx netmask 255.255.255.255
isakmp identity address
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash sha
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup mcsante address-pool clientpool
vpngroup mcsante dns-server 192.168.15.200
vpngroup mcsante default-domain esfest.local
vpngroup mcsante split-tunnel SPLIT
vpngroup mcsante idle-time 3600
vpngroup mcsante password cisco1234!
telnet 0.0.0.0 0.0.0.0 outside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh 0.0.0.0 0.0.0.0 inside
ssh timeout 60
management-access inside
console timeout 0
dhcpd address 192.168.15.2-192.168.15.254 inside
dhcpd dns 10.250.xxx.xx 10.250.xxx.xx
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside
username Administrator password eb2xNOqOUnTzuIeB encrypted privilege 15
terminal width 80
Cryptochecksum:34371468d4351b940b8d209d7d92ffca
Xerox2(config)#
DavidlocAsked:
Who is Participating?
 
geergonConnect With a Mentor Commented:
Remove this line:
crypto dynamic-map vpnclient_map 20 match address ra_crypto_acl

Also the SPLIT acl should be:
access-list SPLIT permit ip 192.168.15.0 255.255.255.0 10.3.3.0 255.255.255.0
0
 
DavidlocAuthor Commented:
Will try this tommorow , thank you :)
0
Evaluating UTMs? Here's what you need to know!

Evaluating a UTM appliance and vendor can prove to be an overwhelming exercise.  How can you make sure that you're getting the security that your organization needs without breaking the bank? Check out our UTM Buyer's Guide for more information on what you should be looking for!

 
DavidlocAuthor Commented:
The Access Split is for the Dynamic 20 and is correct btw
0
 
DavidlocAuthor Commented:
I just checked


crypto dynamic-map vpnclient_map 20 match address ra_crypto_acl

This is how the IPSEC policy is matched to :

access-list ra_crypto_acl permit icmp any 10.3.3.0 255.255.255.0


Which has the wrong protocol , of course. (ICMP should = IP )

Your answers are not complete but they did guide me in the correct direction , thank you very much


0
 
DavidlocAuthor Commented:
crypto dynamic-map vpnclient_map 20 match address ra_crypto_acl

This is how the IPSEC policy is matched to :

access-list ra_crypto_acl permit icmp any 10.3.3.0 255.255.255.0


Which has the wrong protocol , of course. (ICMP should = IP )

0
 
geergonCommented:

I am agreed with you, my answer not all the time are complete, I apologize.
The issue is this: According to my experience not all the people knows how dynamic crypto maps
works. I mean I did not know before... This thing is kinda old school from the PIX 6.3

Please for better understanding read this article "dynamic crypto maps"
http://www.cisco.com/en/US/docs/security/pix/pix63/command/reference/c.html#wp1085720
0
All Courses

From novice to tech pro — start learning today.