How can we restrict the smtp attachment size in Lotus Domino send out using notes.ini setting

How can we restrict the SMTP attachment size in Lotus Domino send out using notes.ini  setting
jobby1Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jmaritzCommented:
The following steps restrict inbound and outbound smtp size at the same time.

From the domino admin help

1)
Make sure you already have a Configuration Settings document.
From the IBM® Lotus® Domino® Administrator, click the Configuration tab and expand the Messaging section.
Click Configurations.
Select the Configuration Settings document for the mail server or servers you want to administer, and click Edit Configuration.
Click the Router/SMTP - Restrictions and Controls - Restrictions tab.
Complete these fields in the Router Restrictions section, and then click Save & Close:

 
Maximum message size
 The maximum message size in KB (thousands of bytes) the server accepts. The Router rejects any messages that exceed this size for both transfer and delivery.
The default is 0 KB, which does not limit message size.

2)
If you only want to restrict outbound only, not sure why you want to do this but if you do the following wing steps from the help it will first send the size to the taget server, if your message is to big it will not send the message.

Click the Router/SMTP - Advanced - Commands and Extensions tab.
Complete these fields in the Outbound SMTP Commands and Extensions section, and then click Save & Close:
Field
 Enter
 
SIZE extension
 Choose one:

Enabled - (default) If the destination SMTP host also supports the SIZE extension, Domino declares the estimated size of messages before transfer.
Disabled - Domino does not declare message size before transferring messages to another SMTP server.
 
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
akhafafCommented:
     Hi there Jobby,,,

-AFAIK,, there is no way you can do it using  Notes.ini on the server side while it can be done on the client side of Inotes, but I am really enclosing these links and I hope you can get  something out .
http://www.ibm.com/developerworks/lotus/documentation/notes-ini/ftoj.html
http://searchdomino.techtarget.com/generic/0,295582,sid4_gci1251434_mem1,00.html

- The only remaining way which comes to my mind is to create a rule on the SMTP server  
Edit Server Configuration
Router/SMTP
Restrictions and Controls
Rules
New Rule
Size( In bytes)==> Greater Than

Best Wishes
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Protocols

From novice to tech pro — start learning today.