[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 980
  • Last Modified:

SBS 2003 static routes for dedicated Internet connection

Hi,

We have the following setup (SBS 2003 - 2 NICs):
Internet – Modem (10.10.6.10) – Server NIC 1 (10.10.6.51) / Server NIC 2 (192.168.1.1) – Local network
Local Network 192.168.1.x / 255.255.255.0

We have been asked by the ISP people (dedicated connection for a specific application) to configure the following:
"New router will be given the IP 192.168.1.201/24.
Add static routes to default gateway for the following IPs to be sent to the new router (192.168.0.201):
10.2.1.25
10.2.1.27
10.2.1.30
10.2.1.32
10.1.1.22
10.1.1.33
And can the following DNS entries be added:
RPMPROD           10.2.1.32
RPMSTAGE         10.1.1.22
RPMTRAIN          10.2.1.27
RPMDOCS           10.2.1.30
RPMSQL               10.2.1.25


Not too sure where to go.
Thanks in advance.

Ron
0
astrosbs
Asked:
astrosbs
  • 9
  • 6
1 Solution
 
ina_donCommented:
Are you using ISA Server on your SBS?
0
 
Rob WilliamsCommented:
>>""New router will be given the IP 192.168.1.201/24.
Add static routes to default gateway for the following IPs to be sent to the new router (192.168.0.201):"
Is the new router 192.168.1.201 or 192.168.0.201? You show both.
How will the new router be connected to your network?

I will assume router is connected to the LAN side of the network and its IP is 192.168.1.201:
The SBS (with 2 NIC's) is the default gateway so it will be where you need to add the routes SBS using a command line:
route  -p  10.2.1.25  mask  255.255.255.255  192.168.1.201
route  -p  10.2.1.27  mask  255.255.255.255  192.168.1.201
route  -p  10.2.1.30  mask  255.255.255.255  192.168.1.201
route  -p  10.2.1.32  mask  255.255.255.255  192.168.1.201
route  -p  10.2.1.22  mask  255.255.255.255  192.168.1.201
route  -p  10.2.1.33  mask  255.255.255.255  192.168.1.201

if you need to remove a route use:
net delete 10.21.1.xx  (where xx = appropriate IP)

For the DNS entries open the DNS management console | expand the server name | expand forward lookup zones | right click on your domain name and choose new Host (A) | enter the name and IP (this assumes they use the same domain name) | check the box to create an associated PTR record.

If those names are not using the same domain suffix you either need to get the domain name and create a new forward lookup zone or use them as NetBIOS names and add them to WINS or use an LMHosts file. For the latter see:
http://msmvps.com/blogs/robwill/archive/2008/05/10/lmhosts-and-hosts-files.aspx

If the server is running ISA, it complicates matters and you will have to create rules for those IP's
0
 
astrosbsAuthor Commented:
Hi guys,
There no ISA running on the server.
Yes, the new router is 192.168.1.201.
I'm not too sure about the DNS entries. All I know is that this dedicated connection is for a secure connection to an online database.
Thanks Rob, for the info, I'll check it out and get back to you :)

0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
Rob WilliamsCommented:
Online database; Do you know why there are so many IP's and why they are not sequential? Not a problem, but I am surprised. The routes should work fine then, and I suspect you would be better with LMHosts file, than DNS entries, but they can confirm that.
0
 
astrosbsAuthor Commented:
I got the following error when adding the routes:

Invalid MASK generates an error, that is when (DEST & MASK) != DEST.
<Example> route ADD 157.0.0.0 MASK 155.0.0.0 157.55.80.1 IF 1
The route addition failed: The specified mask parameter is invalid.
stination & Mask) != Destination.
0
 
astrosbsAuthor Commented:
LMhosts ok but that means I'll need to do it on all computers, right?
0
 
Rob WilliamsCommented:
>>"Invalid MASK...."
Try adding the interface such as:
route  -p  10.2.1.25  mask  255.255.255.255  192.168.1.201 IF 10
the  route print   command should give you the interface # list. You need the IF # for the 192.168.1.1 NIC

>>"LMhosts ok but that means I'll need to do it on all computers, right?"
Yes unless only the SBS or the application running on the SBS needs the route.
0
 
astrosbsAuthor Commented:
Tried, same error, I must be missing something :(

With the PRINT Command:

IPv4 Route Table
===========================================================================
Interface List
0x1 ........................... MS TCP Loopback interface
0x10003 ...00 18 71 77 82 52 ...... HP NC7781 Gigabit Server Adapter
0x10004 ...00 0f b5 fb b0 c9 ...... NETGEAR GA311 Gigabit Adapter
===========================================================================
===========================================================================
Active Routes:
Default Gateway:         10.10.6.1
  None
Persistent Routes:
  None

ROUTE PRINT:

Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0        10.10.6.1       10.10.6.51      1
        10.10.6.0    255.255.255.0       10.10.6.51       10.10.6.51     20
       10.10.6.51  255.255.255.255        127.0.0.1        127.0.0.1     20
   10.255.255.255  255.255.255.255       10.10.6.51       10.10.6.51     20
        127.0.0.0        255.0.0.0        127.0.0.1        127.0.0.1      1
      192.168.1.0    255.255.255.0      192.168.1.1      192.168.1.1     10
      192.168.1.1  255.255.255.255        127.0.0.1        127.0.0.1     10
    192.168.1.255  255.255.255.255      192.168.1.1      192.168.1.1     10
        224.0.0.0        240.0.0.0       10.10.6.51       10.10.6.51     20
        224.0.0.0        240.0.0.0      192.168.1.1      192.168.1.1     10
  255.255.255.255  255.255.255.255       10.10.6.51       10.10.6.51      1
  255.255.255.255  255.255.255.255      192.168.1.1      192.168.1.1      1
Default Gateway:         10.10.6.1
===========================================================================
0
 
astrosbsAuthor Commented:
Ended up using the PRINT ADD command and it worked.
0
 
Rob WilliamsCommented:
I am not familiar with using the "PRINT ADD command" for this. How were you able to resolve.
Thanks,
--Rob
0
 
astrosbsAuthor Commented:
as far as I remember, I used route print  10.2.1.25  mask  255.255.255.255  192.168.1.201
0
 
astrosbsAuthor Commented:
sorry meant route ADD 10.2.1.27 MASK 255.255.255.255 192.168.1.201
0
 
Rob WilliamsCommented:
Is that not what I had suggested?
Keep in mind when you reboot you will loose the route unless you add "-p" making it permanent:
route -p ADD 10.2.1.27 MASK 255.255.255.255 192.168.1.201
           ^
0
 
astrosbsAuthor Commented:
yep partially :) just missing the "ADD"
0
 
astrosbsAuthor Commented:
Partially answered
0
 
Rob WilliamsCommented:
Very sorry about that. I didn't notice I missed the 'add', obviously very critical. I remember writing the first route and after that just cutting and pasting the same incorrect statement. Glad to hear you got it working though.
0

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 9
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now