Boot error with Windows Deployment Server.

asasupport
asasupport used Ask the Experts™
on
I'm having a serious issue which is driving me nuts!!  I have installed WDS on a Server 2008 x86 VM.  MDT 2010 and AIK x86 also installed.  

Windows 7 Boot images (both x64 and x86) have been added to the boot folder in WDS.  Our DHCP Server options have been set to Option 066 Boot Server Host Name WinSrv2008.asa.local.  Option 067 Bootfile Name: boot\x86\wdsnbp.com.  I've also changed the properties of the WDS server Boot tab to reflect the same changes, i.e. Boot\x86\wdsnbp.com.  I understand the default is  Boot\x86\pxeboot.com


WDS and DHCP are on different servers but same subnet.

However, when I go to boot up a client PC, I get the following error caught on a loop:

Architecture: x64

Contacting Server: x.x.x.x

TFTP Download: Boot\x64\wdsnbp.com

I'm trying to boot the x86 image!!  The server OS, WDS and AIK are all x86.  I also changed the boot file back to the default  Boot\x86\pxeboot.com on both the DHCP server and on my WDS but to no avail.


Any help or advice would be greatly appreciated!!

Thanks,

Yvette
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Are you using SCCM at all?

http://www.windows-noob.com/forums/index.php?/topic/546-how-can-i-troubleshoot-windows-pe-booting-in-sccm/


Is your question mainly dealing with the x64 boot image being select instead of an x86 version.
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
Thank you for your replies.

We're not using SCCM.  I also set the autodiscovery in WDS with the following syntax:

wdsutil /set-server /architecturediscovery:yes

Command was successful but didn't make any difference.....
I'm not too familiar with native wds (non-SCCM).. but maybe the workstation is 64 compatible...and this is why the 64 image is being selected...

try

wdsutil /set-server /architecturediscovery:no
An x64 compatible client will always boot using an x64 image. If you then select an x86 install image/task then it will carry on as normal. It needs to use the x64 image as the machine does not know what architecture you want.

Author

Commented:
Thanks for this.

I'm pretty new to WDS so youll have to bear with me.

This still doesn't explain why the TFTP Download: Boot\x64\wdsnbp.com is caught in a loop though when booting.  It appears to be reading the bootfile Boot\64 even though I've set this to Boot\x86\wdsnbp.com in both DHCP and the WDS server.

Any ideas??

Many thanks.
If you are just doing Windows 7 deployment from the WDS server then there is no need to configure the settings you are using. If your DHCP server is on windows you don't need the DHCP boot options as the WDS server is authorised. You can leave the 'Default boot image' section blank. WDS works with minimal configuration and it looks like you may of over-complicated things for yourself.

Do you have any other pxe/bootp processes running on your network? If so then the above could be wrong.

Author

Commented:
More information was needed to complete my task.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial