• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 459
  • Last Modified:

tween (zigoengine) delay is not working? AS2 FLASH


I am trying to tween one image in first then a second but they are coming in at the same time for some reason..

ive used this before and its worked so i am confused!

Thanks a lot.
import com.mosesSupposes.fuse.*;
ZigoEngine.register(FuseItem, PennerEasing);

start_scale = 75;
ease = 'easeOutBounce';
tween_time = 1.5;

com.mosesSupposes.fuse.ZigoEngine.doTween({target: bike_front, start_alpha: 100, alpha: 100, ease: ease, seconds: tween_time, start_x: bike_front._x - 100, x: bike_front._x});
com.mosesSupposes.fuse.ZigoEngine.doTween({target: bike_back, start_alpha: 100, alpha: 100, ease: ease, seconds: tween_time, start_x: bike_back._x - 100, x: bike_back._x, delay: tween_time / 40});

Open in new window

1 Solution
hi i'm not familiar with the zigoengine, had a look at the documentation but i think that's a later version.
but i can't get your file to do anything even with changing the code to version 2.1

kikisuAuthor Commented:
Hi, Thanks a lot for having a look!

Im not sure whats wrong but i added some more frames to the timeline and added the second picture later on rather than trying to do everything in one frame. So its doing what i want now - just a different way.

Thanks for your time :-)
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Easily Design & Build Your Next Website

Squarespace’s all-in-one platform gives you everything you need to express yourself creatively online, whether it is with a domain, website, or online store. Get started with your free trial today, and when ready, take 10% off your first purchase with offer code 'EXPERTS'.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now