How do I prevent bounce-backs while sending mail via local smtp server, but receiving mail through Google Apps Domain?

We recently migrated to Google Apps and are sending and receiving mail through Google now.  However, I have several users who often send out emails to distribution lists of 600 - 800 addresses.  Google limits are set at 500 so I configured these users to send out mail using our own smtp server so they could get around these restrictions.  However, it appears that two to three ISPs or domains are blocking emails because of the following reasons:

host[] said: 454 5.7.1 DXNS3 Message refused. Your host name dosen't match with your IP address. If you need, please contact (in reply to end of DATA command)


host[] said: 450 4.7.1 Client host rejected: cannot find your hostname, [] (in reply to RCPT TO command)

I have already tried to contact about how to fix this, but they haven't responded.  I'm sure the issue is related to how we are sending mail through our own mail server and then receiving mail from Google, but I just don't know enough about this stuff to fix it.  Thanks for your help.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Quite simpe to fix.  You need to add an SPF record to your domain name.

The SPF record will contain the IP address of the server you are sending from.  When you send a bulk e-mail, the recipients servers will do a lookup and see that your IP address is allowed to send e-mails on behalf of your and allow it through.

Your DNS registrar will be able to help you set it up.  Make sure you give them the correct IP address though (it will be external IP address that your sending server will present to the outside world).

This wikipedia article explains what it is in more detail: -
Todd GerbertIT ConsultantCommented:
I think an SPF record will you no good.

Your issue appears to be that your mail server is saying "Hi, I'm" but there is no "" in DNS, or the reverse lookup of your mail servers IP address does not result in ""

Is your mail server's IP address static?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Your send e-mail server will have a fully qualified domain name in the SMTP server settings.  You need to get a reverse DNS entry setup for your IP with the same fully qualified domain name as your sending server (i.e.

You will also need the SPF record setup regardless as your mail will get rejected or treated as SPAM.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.