IIS stops responding, server needs to be restarted

We have a webserver running Windows 2003 SP2.

After a memory upgrade(2gb to 4gb), IIS stops responding and the only way to get it back is to restart the server.

Some errors on event viewer:

Application:
Reporting queued error: faulting application w3wp.exe, version 6.0.3790.3959, faulting module w3core.dll, version 6.0.3790.4616, fault address 0x00004e2e.
EventID 1004

System:
A process serving application pool 'AppPool Site CCE' terminated unexpectedly. The process id was '5004'. The process exit code was '0xc0000005'.

A process serving application pool 'AppPool Site CCE' terminated unexpectedly. The process id was '3728'. The process exit code was '0x1'.

After restarting the server, during the days we got some AppPool errors on event viewer. And after a week(3d time this happens) IIS stops responding. Restarting the service, restarting the AppPool, nothing works, only restarting the PC.

I installed Debug Diagnostic Tools and created a rule monitoring the Application Pool but the log shows nothing...

Any thoughts?
cce-puc-rioAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

willk400Commented:
What version of Server 2003 are you running? (i.e. web edition, enterprise, standard, datacenter, etc...).
0
cce-puc-rioAuthor Commented:
Standard SP2.
0
willk400Commented:
Is the Identity for the application pool you are having issues with running with Configurable (i.e. an IWAM account, or an account created to run it), or is it one of the predefined accounts. If you havnt tried to set it to use the IWAM account I would reccomend trying that.
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

cce-puc-rioAuthor Commented:
We are using the predefined "network service"

You´re sayin to change to "configurable" and set IWAM account? Im gonna try that.

Just for information, whats the difference?
0
cce-puc-rioAuthor Commented:
Still having this issue. It´s not permission because everything on the site works fine for a week. Anyone else has any thoughts?
0
cce-puc-rioAuthor Commented:
Please close the topic. We isolated the DLLs on different Application Pools and find out wich one was causing the error.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.