OWA Certificate

I installed a new certificate on our Exchange server for our OWA website.  I'm confused now as the new certificate isn't being given to our users.  When I check the site security it shows the new certificate but when I connect via a web browser it shows the old cert.
Who is Participating?
alegreConnect With a Mentor Author Commented:
well, sorry for the question.  It looks like the firewall needed the cert.  Once I gave the firewall the cert for the website it began to send it on to the end user browser.
Jon BrelieSystem ArchitectCommented:
Restart Exchange, IIS, and clear your browser info and restart.  Do you get the new cert now?
alegreAuthor Commented:
No, and it is funny, when I connect to the site on my internal network the certificate works fine, but when I connect on the external side I get the old cert.
Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

Glen KnightCommented:
Which version of Exchange?
You will have to install the new cert in the browser.
Jon BrelieSystem ArchitectCommented:
that makes sense.  Thanks for the update.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.