SMTP errors on exchange 2003 and emails stuck in queue

This server has been working for a few months now but we just started noticing this issue. I am getting only certain emails stuck in the exchange 2003 queue. When I click on the emails in the bottom left in the exchange system manager it says "An SMTP protocol error ocurred." Some of the emails are returned back to the user and have the following error: Relay access denied (in reply to RCPT TO command)

Here is a report from mxtoolbox, which shows " Warning - Reverse DNS does not match SMTP Banner". I am thinking this is somehow related to the other issues, am I correct?

220 cs.server.local Microsoft ESMTP MAIL Service, Version: 6.0.3790.3959 ready at Thu, 25 Mar 2010 11:34:44 -0400


 Not an open relay.
 0 seconds - Good on Connection time
 0.078 seconds - Good on Transaction time
 OK - 66.89.155.122 resolves to
 Warning - Reverse DNS does not match SMTP Banner

Session Transcript:
HELO please-read-policy.mxtoolbox.com
250 cs.server.local Hello [64.20.227.133] [47 ms]
MAIL FROM: <supertool@mxtoolbox.com>
454 5.7.3 Client does not have permission to submit mail to this server. [31 ms]
qbarat2Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Alan HardistyCo-OwnerCommented:
Please have a read through my EE Article for this exact problem.

Check your settings, correct your Reverse DNS settings and anything else that the tests highlight and you should be able to get your mail flowing properly:

http://www.experts-exchange.com/articles/Software/Server_Software/Email_Servers/Problems-sending-mail-to-one-or-more-external-domains.html
0
Jon BrelieSystem ArchitectCommented:
In addition to Alan's article, it is important to point out that your SMTP Banner (also known as the FQDN in Exchange) does NOT have to match the domain name you are sending email for.  It only needs to match the rDNS entry for your public mail origin IP address.

For instance, if you "nslookup x.x.x.x" (substitute your IP) and that returns "some-long.ID.string.your.isp.com", then that is what you should set your FQDN to.

Ideally, you would contact your ISP and ask them to set it to something sane like "mail.yourdomain.com" but this is not always an option.
0
qbarat2Author Commented:
Thank you very much for the information. I have on question though, this server is also acting as a domain controller with active directory, is there a way to change the FQDN without having to completely reconfigure the domain or possibly format?

Also, if this is not an option will having the ISP change it to "cs.server.local" work? I can have them change it, just dont know if this will do the trick?
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Jon BrelieSystem ArchitectCommented:
Your FQDN is a setting in exchange and will not impact your Domain settings.  Your ISP will not setup an rDNS record to cs.server.local.  That is not a functional TLD like .net .org, or .com.

0
Jon BrelieSystem ArchitectCommented:
To find the FQDN in Exchange 03:
Open ESM
Drill down to Admin Group, Server, protocol, SMTP
right click your SMTP server and get properties.
click the Delivery tab
Click Advanced
the field you want is "Fully-qualified domain name"

This will not affect your AD install.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
qbarat2Author Commented:
Thank you very much Enphyniti, if this works I will accept your solution. I am just waiting on the ISP to implement the change and then I will know for sure if it works. (I had them change it and I just changed it to match the requested changes)
0
qbarat2Author Commented:
Thank you! This is what I was looking for. After making the change with the ISP and changing the FQDN as described, my problem is solved
0
Alan HardistyCo-OwnerCommented:
So I guess you didn't read my article then as the FQDN is clearly mentioned in it!
0
qbarat2Author Commented:
I read your article and it was helpful (I marked your comment as helpful), but it didn't give me exact instructions. After reading that article I got confused trying to change the FQDN of the server which after researching it was a very complicated thing to do. Enphyniti cleared this up for me by giving me the instructions I needed to change the FQDN within the exchange system manager.

Sorry, but I was unable to solve my problem with just that article. I do thank you for the input, it certainly led me in the right direction.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.