[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1487
  • Last Modified:

Server 2008r2, access denied when trying to start a service using net start

Server 2008r2, access denied when trying to start a service using net start. Works fine from services gui.
0
TeaPartysRock
Asked:
TeaPartysRock
  • 3
1 Solution
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
Make sure you are running a command prompt as administrator - by default, command prompts do not run as administrator.
0
 
TeaPartysRockAuthor Commented:
Thanks for the quick response. I tried cmd prompt as admin as you suggested. It did let me start service. I'm trying to start services via Backup Exec post command script. It is failing so I tried locally on the server. I am admin on box, so was confused why it would fail. I'm new to 2008. Any ideas on running script from Backup Exec server?
0
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
Sorry, as it pertains to Backup Exec, I don't know what to tell you.  I would suggest either a new question in the Backup Exec zone and/or a call to Symantec.

(Actually, you MIGHT be able to turn UAC off on the server - but I would REALLY ADVISE AGAINST THIS)

What are you trying to stop/backup?

Perhaps an alternative workaround in which you create a scheduled task that kicks off a few minutes before your backup and then runs again a few minutes after it should have ended?  Or maybe Backup Exec can have the particular job kicked off from the command line - in which case, a batch file could work as a scheduled task.  Another option might be to use SC and/or PSEXEC in an effort to elevate the privilages for the NET STOP or SC STOP commands.
0
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
I object.

The asker acknowledged that my solution worked - THEN added this needed to be done involving third party software.  A response was promptly posted and the asker failed to continue to participate in his own question.

Thus, the question that was asked was correctly answered.

-Lee
0

Featured Post

2018 Annual Membership Survey

Here at Experts Exchange, we strive to give members the best experience. Help us improve the site by taking this survey today! (Bonus: Be entered to win a great tech prize for participating!)

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now