cfajaxproxy problem in Coldfusion 9

We just upgraded to ColdFusion 9 on a Windows Server 2003 box that uses IIS 6 to serve the sites.

 
Now that we've upgraded all of our <cfajaxproxy> tags are broken.  Sample code attached.  The cfcs reside in the same directory as the cfm pages but we are getting an error that says "The specified CFC getReports could not be found.  
The path to the CFC must be specified as a full path, or as a relative path from the current template, without the use of mappings."

 
It doesn't make sense that if they are in the same directory as the calling program then why can't it find them.
<cfajaxproxy cfc="getReports" jsclassname="GetReportsInfo">

Open in new window

AGenMISAsked:
Who is Participating?
 
AGenMISConnect With a Mentor Author Commented:
The problem had to do with the use of virtual directories in IIS 6.0.  The cfc resides in a virtual directory named CAR therefore the virtual directory had to be included in the path using dot notation.


Code that worked in CF 8.0.1 but not in CF 9.0
<cfajaxproxy cfc="getReports" jsclassname="reports">

Code that now works in CF 9.0
<cfajaxproxy cfc="CAR.getReports" jsclassname="reports">

Open in new window

0
 
azadisaryevCommented:
first, let me assure you that <cfajaxproxy> tag in cf9 works as expected.

now, things to check:
- is the cfc found if you use <cfinvoke> to invoke it or do you see the same error?
- in cf9 administrator, go to Server Settings -> Caching and click "Clear Component Cache" button at the bottom of the page.
- in cf9 admin, check if you have a mapping for / under Server Settings -> Mappings. if you do, see if removing it solves the issue.

these are just couple of things to check off the top of my head...

Azadi
0
 
AGenMISAuthor Commented:
1.  I can invoke the component without error
2.  I cleared the cache but still get the error
3.  I only have two mappings, one for /CFIDE and one for /gateway.  The cfc that I'm trying to use is not in either one of these mappings.
0
Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

 
thecfguyCommented:
We have just migrate from cf8 to cf9 and it work as expected. Only issue with cf8 to cf9 migration is CF9 is using ExtJs 3.0 which cause javascript error if you have modified cfgrid or any other ajax functionality.

Make sure you have added CFIDE as virtual directory in website. Also if you are looking for cfgrid related enhancement visit my blog http://www.thecfguy.com colfusion 9 category
0
 
AGenMISAuthor Commented:
We have CFIDE as a virtual directory for the site.  The errors that we are getting do not appear to be related to javascript because we are getting CF errors before the page will load completely.
0
 
azadisaryevConnect With a Mentor Commented:
are the page and cfc in your web root or in a sub-folder?
are you sure it is <cfajaxproxy> tag that's causing the error? do you have any cf ajax ui controls on the page that bind to the same cfc?

Azadi
0
 
thecfguyCommented:
can you attach screenshot of error? Sometimes it helps lot to solve error
0
All Courses

From novice to tech pro — start learning today.