Exchange 2007 Public Folders not accessible in Outlook 2003

I am migrating from Exchange 2003 to 2007 and I have moved all mailboxes to the new Exchange server but I have a problem with the Public Folders. I have replicated all Public Folders from the Exchange 2003 box to 2007 and have now removed the Exchange 2003 replicas. All of my clients are Outlook 2003 and when I dismount the Public Folder store on 2003, my clients are no longer able to connect to the Public Folders which also affects free/busy data. If I mount the 2003 Public Folder store, the clients can access the folders again.

Any suggestions would be greatly appreciated.
I_play_with_DNAAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

CompanionCubeCommented:

Change the Default PF on the Mailbox Store to point to the E2K7 PF store.
0
I_play_with_DNAAuthor Commented:
I've followed the technet KB but my clients still can't open Public Folders without the 2003 Public Folder store mounted.
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

CompanionCubeCommented:
Close Outlook, reopen Outlook, try again

Can you tell where the users are connecting to access the PFs? With Outlook open, hold down the Ctrl key | right-click the Outlook tray Icon (next to the system clock) | select Connection Status from the pop-up menu
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
I_play_with_DNAAuthor Commented:
Closing Outlook and restarting didn't help. When I look at the connection properties, I see 3 Public folder connections to the old server and 2 to the new one.
0
I_play_with_DNAAuthor Commented:
I found http://support.microsoft.com/kb/945602 and followed through with it but when I search for replicas it still shows this:

Name     : SCHEDULE+ FREE BUSY
Replicas : {}

Also when I look at the replication status of the Public Folders on the Exchange 2007 box through the 03 System Manager it shows "data not available" for the Schedule+ Free Busy folder.

I'm stumped...

0
Schnell SolutionsSystems Infrastructure EngineerCommented:

Did you resolve this problem?

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.