Windows cannot process the object with the name because of the following error: there are no more endpoints available from the endpoint mapper

When trying to add a user to the local admins group on a Windows 2003 Enterprise edition server, I get the error.  Windows cannot process the object with the name because of the following error: there are no more endpoints available from the endpoint mapper.

I restarted the netlogon service, confirmed that time matched up to the DC, plenty of disk space, a gig of Ram free, and connectivity to DNS servers works.  

Any other ideas ?
Elemental12Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mike KlineCommented:
There is a lengthy article here on trying to resolve it

http://support.microsoft.com/kb/839880

As you can see there they are pointing you to first look for firewall/port issues.

Any events in your logs and does dcdiag look ok?

Thanks
Mike

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AwinishCommented:
I got for the solution & somewhere,i found the below solution.
1. Click Start, click Run, type regedit, and then click OK.
2. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
3. If the EnableRSS registry entry does not exist, create it.
To do this, follow these steps:
a. On the Edit menu, point to New, and then click DWORD Value.
b. In the New Value #1 box, type EnableRSS, and then press ENTER.

4. Right-click EnableRSS, and then click Modify.
5. In the Value data box, type 0 (zero), and then click OK.
6. Exit Registry Editor.
Try above solution & if it doesn't work try to reset the secure channel,by disjoining the machine & rejoingin it with different name.

Check there is no firewall blocking the client request on problem server & there is no dns issue on the DC.
Elemental12Author Commented:
Firewall blocked some funky microsoft port.

Thanks
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
OS Security

From novice to tech pro — start learning today.