[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1211
  • Last Modified:

Inserting records to MySQL Linked Server from SQL Server 2008

I have a Linked MySQL Server. This statement works fine:

SELECT * FROM OPENQUERY(MYSQL,
'select Symbol  from reg_show.tblTest')

(there is a tblTest in MySQL db that has a single column Symbol varchar(10).
But when I try to insert records into MySQL from MSSQL server :

INSERT OPENQUERY(MYSQL,
'select Symbol  from reg_show.tblTest')
VALUES ('DD')

I get this error :

"OLE DB provider "MSDASQL" for linked server "MYSQL" returned message "[MySQL][ODBC 5.1 Driver][mysqld-5.0.27-community-nt-log]Commands out of sync; you can't run this command now".
0
larisa1970
Asked:
larisa1970
1 Solution
 
Guy Hengel [angelIII / a3]Billing EngineerCommented:
maybe this helps:
http://www.ideaexcursion.com/2009/02/25/howto-setup-sql-server-linked-server-to-mysql/

I keep running into a funny issue with my Linked Server setup. If I have the “Don’t cache results” and “Force forward only cursors” options checked, any time I run an insert I get:
“OLE DB provider “MSDASQL” for linked server “test” returned message “[MySQL][ODBC 3.51 Driver][mysqld-5.0.77-log]Commands out of sync; you can’t run this command now”.”

I can run the inserts without these options checked but after some time the MySQL server returns an “Out of Memory” error (which I imagine is do to it caching results). Anyone have some insights into this?

Open in new window

0
 
larisa1970Author Commented:
Yes!!!!! That's exactly the same issue that I had.

To run inserts
 “Don’t cache results” and “Force forward only cursors” have to be unchecked.
Which I'm sure would bring other problems later but for now I'm able to insert.

Thanks for your help, angelII!
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now