Inserting records to MySQL Linked Server from SQL Server 2008

I have a Linked MySQL Server. This statement works fine:

SELECT * FROM OPENQUERY(MYSQL,
'select Symbol  from reg_show.tblTest')

(there is a tblTest in MySQL db that has a single column Symbol varchar(10).
But when I try to insert records into MySQL from MSSQL server :

INSERT OPENQUERY(MYSQL,
'select Symbol  from reg_show.tblTest')
VALUES ('DD')

I get this error :

"OLE DB provider "MSDASQL" for linked server "MYSQL" returned message "[MySQL][ODBC 5.1 Driver][mysqld-5.0.27-community-nt-log]Commands out of sync; you can't run this command now".
larisa1970Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Guy Hengel [angelIII / a3]Billing EngineerCommented:
maybe this helps:
http://www.ideaexcursion.com/2009/02/25/howto-setup-sql-server-linked-server-to-mysql/

I keep running into a funny issue with my Linked Server setup. If I have the “Don’t cache results” and “Force forward only cursors” options checked, any time I run an insert I get:
“OLE DB provider “MSDASQL” for linked server “test” returned message “[MySQL][ODBC 3.51 Driver][mysqld-5.0.77-log]Commands out of sync; you can’t run this command now”.”

I can run the inserts without these options checked but after some time the MySQL server returns an “Out of Memory” error (which I imagine is do to it caching results). Anyone have some insights into this?

Open in new window

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
larisa1970Author Commented:
Yes!!!!! That's exactly the same issue that I had.

To run inserts
 “Don’t cache results” and “Force forward only cursors” have to be unchecked.
Which I'm sure would bring other problems later but for now I'm able to insert.

Thanks for your help, angelII!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server

From novice to tech pro — start learning today.