Problems accessing Companyweb from certain computers

Hi,

I am currently facing a very troublesome issue, that we have been unable to get to the bottom of.

Our client is running a SBS 2008 Server (fully patched including SP2 for Windows, Sharepoint Services, Exchange, etc.).

About 8 of the 46 clients that are joined to the domain are unable to access http://companyweb, yet if they go to https://remote.domainname.co.nz:987 they can access the page fine, all the other computers are fine and have no issues.

Attempting to reach http://companyweb results in the following Internet Explorer error message:
The Page Cannot Be Found (HTTP 400 Bad Request)..

I have run a ipconfig /all on the computers having issues, and they all seem to have the correct settings (all configured to use DHCP from the SBS Server, all picking the SBS Server for DNS and then ADSL router for the gateway), No secondary DNS.

I have run a ipconfig /flushdns on the clients to no effect.

I have run nslookup companyweb and receive what appears to be the correct result:

server: servername.domainname.local
address: 192.168.144.1
name: servername.domainname.local
address: 192.168.144.1
aliases: companyweb.domainname.local

I am also able to ping companyweb, with a reply from the SBS Server from the machines in question.

I have tried logging on as a different user on these machines and even as the domain administrator account and still have the same problem with http://companyweb

The computers that are having the issue are all various brands of machines  (so there is not a common network card driver)and are all running Windows 7 Business Edition.

The firewall on all the PC's in the network is the standard Windows Firewall that has been configured by the default SBS 2008 group policy and the PC's are all running the same Antivirus (NOD32 version 4)

any help or pointers would be greatly appreciated, I am quite sure the problem is with the machines and not the server seeing as so many of the clients do not have the issue but I have been left scratching my head for answers.
safemode_nzAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

shahzadbuxCommented:
have you checked your internet explorer security settings for local intranet?

is http://companyweb in the zones listed sites?
0
MsShadowCommented:
400 bad request means the http request was "malformed".

Have you tried using a different browser?
0
Brad HoweDevOps ManagerCommented:
Hi There,

Sorry to here you are having random errors.

1. Have you cleared the users Internet Explorer Browsing History Temp and
   Cache? Have you tried reseting the Advanced Internet Explorer option to the
   defaults?

2. Have you tried to create a dummy website on the server with a test html
    page to see it if loads?

3. Are these client machines update to date?

4. If you install Firefox on your PC does it produce the same HTTP 400 error?

5. Have you tried removing DNS from the equation entirely and hardcoding hte
    entry into the hostfile?
         ex :   192.168.144.1  companyweb

6. Have you tried disabling the Firewalls or Antivirus temporarily?

7. Are the machines using the DNS configration as the working machines?


Let us know,
Hades666
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

safemode_nzAuthor Commented:
thanks for the ideas everyone, It is now the weekend in New Zealand so I will not be able to test anything for 2 more days, will let you know how I get on.

cheers
0
shahzadbuxCommented:
Have you looked at your application event logs?

Do IIS give any further info?
0
Cris HannaSr IT Support EngineerCommented:
did you join the Windows 7 PCs to the SBS 2008 Server using the http://connect wizard?
0
JoestetzCommented:
Try adding the IP of the server to your hostfile. You could be having routing issues, which would cause some users to not find the server. While this is not the ideal solution, as it will only fix the single user's problem on their computer, it will tell you it is a routing issue on the network.

1) Go to a user having this problem
2) Open up "C:\WINDOWS\system32\drivers\etc\hosts" on their machine
3a) At the bottom, add the IP address of your SharePoint server (192.168.1.100 for example), hit tab, than enter companyweb.com
3b) If you have multiple front-ends, add all front ends as stated above.
4) Close all browser sessions and try again.
0
safemode_nzAuthor Commented:
Hi CrisHanna,

Yes, all the machines have been joined using the http://connect wizard,
I don't think it is relevant, but some of the machine experiencing the issue were previously joined to a different SSB 2003 domain, though they were all unjoined (set back to a workgroup), and then joined using the connect wizard (this is why I ran the ipconfig /flushdns command, just in case it had the wrong dns info for http://companyweb though nslookup has proven it appears correct anyway)

0
Cris HannaSr IT Support EngineerCommented:
You are not by chance running a cisco pix firewall are you?   What are you running for AV on the server and workstations
0
safemode_nzAuthor Commented:
Definitely not running anything Cisco related.

I have rechecked the DNS settings with ipconfig on the machines having issues, and they are definitely connecting to the correct DNS server (the SBS itself)

Running NOD32 version 4.0.474 on the server (with all the correct exceptions) and on most of the workstations (I have just discovered some have a slightly older build of NOD32 4.0.417).

I am going to go and investigate whether all the machines having the issue are running the older NOD32 build as I see in the changelogs some minor issues with the HTTP scanning being fixed (possible cause of this issue).

I am also going to  the HOSTS file and reset Internet Explorer trick (one at a time of course)

Will report back tomorrow evening.
0
safemode_nzAuthor Commented:
Hi everyone,

I have managed to confirm that all the computers exhibiting the issue were running the older build of NOD32, updating them to the same build has resolved the issue completely.

thank you to everyone for the assistance, funny how such a small thing as a build revision can cause such a issue.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.