Windows 7 cannot ctrl-alt-del

Hello experts,

I installed Ultra VNC on Windows 7 profissional. The Ultra VNC works fine but I can't send ctrl-alt-del.
error msg: ctrl-alt-del require service, no permission.

Thanks for your help.
LVL 5
deibelAsked:
Who is Participating?
 
CoreDigitalConnect With a Mentor Commented:
You need to install UltraVNC server to run "Not as a service".

Regards

Paul
0
 
cganeshkumarTechnology SpecialistCommented:
0
 
Iain MacMillanIT ManagerCommented:
i use UltraVNC with Win 7 fine (its 2008 R2 thats the problem), you need to make sure you have set Win 7 to use CTRL+ALT+DEL in the User Accounts Advanced tab - make sure the tick box is checked to enable.  You also should be using v1.0.8.2.

I have UVNC running as a service and setup the admin settings accordingly -- if your using the windows firewall, make sure the exception is there for the VNC port (normally done for you).  Click the send CAD request once, and after a short pause you should get your login screen up.  I have tested this on several Win 7 Pro 64bit systems.
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
pcfreakerCommented:

Hi,
The Ctrl-Alt-Del keypress may be intercepted by the operating system, and so the viewer program won't be able to detect it and pass it to a VNC Server. Go to the viewer's system menu, which you can access by pressing the "f8" key, left-clicking on the VNC icon at the top left of the viewer window, or right-clicking on the viewer entry in the taskbar. In this menu, you will find a "Send Ctrl-Alt-Del" option. Alternatively, you might find that Shift-Ctrl-Alt-Del works. AltGr-Del often works as well.
If you're running the VNC server as an application under Windows NT/2000/XP then it can only provide remote access to the display if a user is logged in and the workstation is not locked. In order to allow the Ctrl-Alt-Del keypress to work and be accessed even if no user is logged in or it is locked, you must run the VNC server as a system service.
If you're running the VNC server under Windows 95/98/ME then sending a remote Ctrl-Alt-Del function will not work at all. On these platforms, Ctrl-Alt-Del causes all programs, including the VNC server, to halt and bring up a task manager window.
You could also try upgrading your VNC software.
0
 
YCassidyCommented:
Hi.

I have the same trouble.  I have in windows 7 ultra vnc installed as a service in *silent mode.

Any of this commands wirks for me. it always says no permission. what can I change in VNc settings in the computer I want to access.


Thanks.
0
 
Iain MacMillanIT ManagerCommented:
you should open a new question, and read the answer above - you need to install NOT AS A SERVICE.  if you set a connection pwd, you have to enable the setting twice from admin properties.

the latest v1.0.9.5 may fix this issue however, but i haven't tested it yet on 7/2008 - still use RDP for 7/2008.
0
All Courses

From novice to tech pro — start learning today.