• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1065
  • Last Modified:

Authentication failed for production in PickupRequest of Fedex

When using the UserCredential and ClientDetail ,Pickup Request for FedEx is working in testing but when I use it in Live it is not working-gives error Authentication failed.I have changed the url in live from https://gatewaybeta.fedex.com:443/web-services  to https://gateway.fedex.com:443/web-services
0
sdugar
Asked:
sdugar
3 Solutions
 
AgnodasCommented:
try Kembros so that the servers will communicate together
0
 
sdugarAuthor Commented:
Other FedEx service like ShipService,track service is working well in live as well as testing ,only pickup request is not responding.
0
 
ltlbearand3Commented:
One of the following is incorrect in your call to FedEx:

Key
Password
Meter
Account

An error on one of those will usually create the message you received.  Make sure you changed to your production Meter and Account.  Also, you can use your product Key & Password in Development so try those there and see if it works and then change your meter and account. If that does not help, I suggest calling FedEx Technical support to see if they can tell you which one is incorrect.

-Bear
0
 
Siva Prasanna KumarPrincipal Solutions ArchitectCommented:
Looks like those are two different environments, make sure  the user credentials are present in both the environments.

May be your user credentials are not yet deployed in the actual environment. check that with Fedex.
0
 
sdugarAuthor Commented:
Thanks!
0

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now