Free Busy folder will not sync from ex2003 server to ex2010 Error ID No:c1041721

A bit of background on this one.

When migrating the Fublic folder would not move so a new one was setup on the 2010 box EX1. I had some trouble with the OAB not syncing this was eventually over come by changing some the aliases for some distribution lists to not have spaces :sigh:

However the free busy folder on the 2003 box will not sync with the new one created on the 2010 box.

Pic of error message attached.
Sam_RendellAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Sam_RendellAuthor Commented:
0
Sam_RendellAuthor Commented:
I am also getting MSExchangeAssistants error 14031 in the system log.

Which is to do with not being able to locate the free/busy folder.
0
Sam_RendellAuthor Commented:
It seems the EFORMS system folder is also not working.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

BikkelbinkCommented:
Hi Sam,

The 14031 error indicates there is not an Exchange 2010 server with the Free/Busy replica available.
Manually creating this folder is not the way of doing this, so if you did, delete the manually created folders on your Exchange 2010 server.
Can you check if all the Free/Busy folders have the Exchange 2010 server defined as a replica partner? When the replica has been added, there is no need to manually create Free/Busy folders on your Exchange 2010 server. They will be created automatically. When the replica server has been added, it can take about a day or 2 before the eventlog messages are completely gone.

Regards,
BB
0
Sam_RendellAuthor Commented:
Hang a mo, let me be clear.

We created a new public folder on EX1, It starts out with

EFORMS REGISTRY
OFF LINEADDRESS BOOK
SCHEDULE+ FREE BUSY

The first thing we noticed on the Monday after the migration was the OAB was not being downloaded by clients on the new exch boxes. This was because the contents of the OAB were not replicating from the old server.

Once some problematic distribution lists had had their aliases adjusted the replication went ahead and now the OAB is populated in the new PUblic folders and users can download it.

EFORMS REGISTRY
SCHEDULE+ FREE BUSY

Are setup as replication partners between new and old servers, the replication is not happening. It has been a week and they are still empty. When i try to force replication from System Manager on the old server for either folder it errors with the above message.  That said it also errors if I try to force replication for the OAB which has replicated and is now working fine.
0
BikkelbinkCommented:
Are you sure there is nothing blocking any connectivity between your servers?
Couldn't it be, that replication of you OAB PF did not occure, but it is in the 2010 Public Folder because you moved it to the Exchange 2010 server to create the OAB?
Do you see system messages in your Queues (Indicating replication is beeing tried)?

0
Sam_RendellAuthor Commented:
I'm willing to entertain any idea.

I see no queues from the old server to the new.

I was not the one who got the OAB going but that's what he thought he had done.

Looking in SM of the old mail server it shows EX1 as a replication partner at the container level but not as the OAB Version level.

I just added EX1 as a partner on for OAB version 2 folder and it now shows EX1 as in sync and the version2 folder has appeared on EX1.

Is it possible then that what he actually did was make a new OAB and it just rebuilt it's self? And replication will now work for OAB because there is a viable target on EX1?

If so what do I need to do for the unusable folders on EX1?

0
BikkelbinkCommented:
If you configured replication of PF on your Exchange 2003 server, the sub-folders aren't automatically updated.
That's why it's best to use the Exchange script AddReplicaToPFRecursive
If you moved the OAB to generate on the Exchange 2010 server, than it will create it in it's own PF.
When reading the above script, it says that setting replication on the top-folder of OAB, Schedule Free Busy and EFORMS isn't supported. (I actually didn't realize that).
So after running the script, you should see the folders beeing replicated to your Exchange 2010 server.

0
Sam_RendellAuthor Commented:
I am having some trouble with script above, am I supposed to download it from somewhere first?

I have found this KB and found that the value for "SiteFolderServer" mentioned in it is indeed a non existent server.

http://support.microsoft.com/kb/284200

However when I try and get the correct value to replace it with I find that the "InformationStore" CN referred to is empty!

This seems likely to be causing problems, any ideas about that?
0
Sam_RendellAuthor Commented:
I am now trying to follow this fix

http://support.microsoft.com/kb/945602/en-us

But where it asks for "–Replicas “Server\Storage Group\Public Folder Database”" I can see no reference to a storage group anywhere in my new exchange administrative group! When I try just "server\DB" it says that it is not compatible.

I am confused.
0
BikkelbinkCommented:
The script is located in the scripts folder where your Exchange 2010 is installed.
When you first run get-publicfolderdatabase it should return the database of your Exchange 2010 server. The name value has to be used when running the script. There are no storage groups in Exchange 2010 anymore.
0
Sam_RendellAuthor Commented:
This is the result from the shell command run the the second KB above. Does this look right to you?



FreeBusyError.jpg
0
BikkelbinkCommented:
It does if your Public Folder database on the Exchange 2010 server is called "Public Folders".
So if you added the server just a moment ago, the folder will show up shortly on your Exchange 2010 server...
Hope it works!
0
Sam_RendellAuthor Commented:
Ok I found the script and ran it as follows

.\addreplicatopfrecursive -toppublicfolder "public folder" -servertoadd EX1

Public Folder is the name of the PF.

 but it said it could not find the PF called "Public Folder" or there was a permissions error.

Do I have the command right?
0
BikkelbinkCommented:
The command should be as followed:
.\addreplicatoprecursive -toppublicfolder "\NON_IPM_SUBTREE" -Servertoadd EX1
The \NON_IPM_SUBTREE are your System Folders.
You "normal" folders are located within \IPM_SUBTREE
After running the script, wait about 10 minutes and run the following command to check if the server has been added succesfully:
get-publicfolder "\NON_IPM_SUBTREE" -recurse | where {$_.replicas -like "*EX1*"}
It should return all the folders that have a replication to the new server.
0
Sam_RendellAuthor Commented:
Hi, the .\addreplica command ran successfully, thanks.

However the command to check the result returns nothing. It does not error but returns nothing at all.

I should add in the public folder management tool in EX2010 FREE BUSY folder has one subfolder named after the new exchange administrative group. The sub folder is empty and will not remove, returning invalid name/permissions error.

My account has all permissions.
0
Sam_RendellAuthor Commented:
UPDATE

When running the get-publicfolder command if I specify *abi-fs02* instead of *EX1* it displays all \NON_IP_SUBTREE folders. Abi-FS02 is the old exchange 2003 box.

Looking in the 2010 EMC it shows EX1 and Abi-FS02 as both being replica partners for the folders.

We just created a test folder under FREE BUSY and gave it Abi-FS02 and EX1 as replica partners, it shows up using the get-publicfolder command when looking for Abi-FS02 and not EX1.

There is something really screwy going on here.
0
Sam_RendellAuthor Commented:
UPDATE

I have just noticed that when I try and add replication parters for the EFORMS REGISTRY folder using the PF management tool it errors on permissions. The script also does not seem to have added EX1 as a replica for that folder.
0
BikkelbinkCommented:
The new Exchange server not showing up using the command line, can be due to replication, give it a moment.
You can and may not add a replication server on the EFORMS REGISTRY. Only the subfolders can have a replication server.
If you run this command:

Get-PublicFolderStatistics | where {$_.itemcount -ne "0"}

It will return most likely none or a few public folders.
If you run it in a couple of hours, there should be more folders.
The script looks for Public Folders that have data on the Exchange 2010 server.
If there are still no PF's on your new server after a couple of hours, then there are some other problems preventing the replication. Keep an eye on the Eventlogs...
Hope the folders will replicate just fine.
0
Sam_RendellAuthor Commented:
It has now been an hour and "get-publicfolder "\NON_IPM_SUBTREE" -recurse | where {$_.replicas -like "*EX1*"}" still returns nothing

Get-PublicFolderStatistics | where {$_.itemcount -ne "0"} returns all the normal public folders and the OAB folders all of which have been replicating since last weekend. None of the EFORMS or FREE BUSY Folders are listed.

0
Sam_RendellAuthor Commented:
I should add that the normal public folders may not have replicated at all as we transferred them using a PST file and the OAB may well have rebuilt it's self on EX1 so there could well have been no replication at all.
0
Sam_RendellAuthor Commented:
This error may be of interest.

Unable to find freebusy public folder: EX:/o=Leadbitter/ou=First Administrative Group on the server: EX1.Leadbitter.local for the user: M******:867a9e9b-4215-4c70-8832-6a45b97e0b0f:b3ae1c00-89b6-4f5a-9d74-6ef8663a49aa:EX1.Leadbitter.local with legacy DN: /o=Leadbitter/ou=First Administrative Group/cn=Recipients/cn=M******

It seems users are still looking for the FREE BUSY folder from the old EX server on the new Ex server. Which would explain why the outlook clients are erroring.  So presumably if the folder replication was working the problem would not exist.

Is there perhaps a way to tell the users to just look at the folder that has been created on the new Ex server?
0
BikkelbinkCommented:
EFORMS can be empty if you do not use Organizational Forms.
And the command:
get-publicfolder "\NON_IPM_SUBTREE" -recurse | where {$_.replicas -like "*EX1*"} EX1 must be the name of your PF Database Name
You can check if the replication schedule is allright for the subfolders of Free Busy. The customer where I'm working right now, replication errors disappeared after a weekend for the Free Busy folders. But they went away eventually

0
Sam_RendellAuthor Commented:
The EFORMS folder is not empty on the original server, it is used by our archive sollution which presently is not working, it contains two sub folders "Forms Library" and "Organizational Forms" .

get-publicfolder "\NON_IPM_SUBTREE" -recurse | where {$_.replicas -like "*Public Folder*"}

Returns the below screen shot which does not list the EFORMS folders from the original Exchange server of the Sub Folder from FREE BUSY on the orignal Exchange server.

I can also add the outlook scheduling (the thing that uses free busy) works fine in OWA, presumably because OWA doesn't use the public folders to obtain the info.
getpub-result.jpg
0
Sam_RendellAuthor Commented:
Is there something I need to run on the old mail server to make it replicate to the new one? I have been running all these scripts and what-not on the new one.
0
Sam_RendellAuthor Commented:
Oh and I checked all folders are set to replicate continuously.
0
Sam_RendellAuthor Commented:
Does this have anything to do with it?

There are a lot of these undeliverable messages queued

From:
ABI-FS02-IS@Leadbitter.co.uk

Envelope Recipients:
SMTP:PublicFolder@Leadbitter.co.uk; SMTP:ABI-FS07-IS@Leadbitter.co.uk;

ABI-FS07 no longer exists. I notice it is also addressed to PublicFolder..?
0
BikkelbinkCommented:
Those are the system messages I mentioned earlier.
These messages is the actual replication. It looks like you FS07 is still somewhere in your AD Configuration.
You can on the EX2003 server, right click a PF and Resend Changes to force a replication.
Is your current Exchange 2010 server renamed, of reinstalled? Was it first named FS07?
To remove the FS07 from your AD Configuration using ADSI can be quite risky.
0
Sam_RendellAuthor Commented:
FS07 died some time ago, it was  a front end mail server doing OWA only. I mentioned earlier it is still listed in ADSI edit as the "SiteFolderServer" for my Exchange organisational group unfortunately I don't see how I can replace it with the public folders on EX1 as the path used involves the database store, which no longer exists in 2010. When I try and enter a different path for the PF on EX1 it errors saying incorrect path type or some such.

The KB I was trying to follow which says it is for Exchange 2010 is here: http://support.microsoft.com/kb/284200
0
BikkelbinkCommented:
This should not be your Exchange 2010 server.
Use your Exchange 2003 server instead.
0
Sam_RendellAuthor Commented:
Use it for what exactly? 2003 has no console that I am aware of.

Anyway I get the feeling we are going round in circles, I have checked all the System folders on the 2003 box are set to have replicas on the 2010 box.

They have done for over a week. The replication is not working. Mostly likely because the system messages we were just talking about are not reaching the correct server.

0
BikkelbinkCommented:
It's hard to explain using a forum and not the old fashioned way. Face-to-face.

What I meant with Use your Ex2k3 server instead, is that what you are trying, using ADSI edit to replace the old FS7 server with the new EX2010 server.
Following the article you talked about, instead of your Ex2010 server, you should replace the FS07 with your Ex2k3 server.
Ex2010 is not in the same Administrative group and does not use the same config as Ex2k3 does.
Your current EX2k3 tries to replicate through the FS07. This doesn't exist anymore so replication does not take place.
When replacing the entry, Your Ex2k3 server will sync directly with Exhange 2010

If above does not work, I'm out of options unfortunately...
0
Sam_RendellAuthor Commented:
Ok sorry I get you now.

I have successfully changed to the "SiteFolderServer" to FS02 which does still exist.

Do I need to restart anything?

I can still see undeliverable messages from  ABI-FS02-IS@Leadbitter.co.uk to SMTP:PublicFolder@Leadbitter.co.uk being generated all the time.

Any thoughts on that?
0
Sam_RendellAuthor Commented:
There also is a queue on the new CAS/HubTransport trying to send to FS02 showing undeliverable.

Am I missing some sort of connector between the two servers?

Cheers,
S.
0
BikkelbinkCommented:
The Exchange information store has to be restarted on the EX2k3 server.
You can check, if the automatically generated Routing Group Connector (during EX2010 setup) has the correct servers listed.
When the above things are done, it should begin replicating...
0
Sam_RendellAuthor Commented:
Ok I think we are making progress.

I have created a new routing Group Connector and all the undeliverable email queues have gone. The queue for the connector filled up on the 2010 box then went out.  On 2003 all the undeliverable mails have moved to the Routing Group Connector queue but are not going out. They are still new ones are no longer addressed to FS07 and just to PublicFolder@domain.

Any ideas why they might not be going?

I just used this shell command to create the routing group.

New-RoutingGroupConnector -Name "Interop RGC" -SourceTransportServers "EXCHSource.SubhashTest.com" -TargetTransportServers "EXCH2k3.SubhashTest.com" -Cost 100 -Bidirectional $true -PublicFolderReferralsEnabled $true
0
Sam_RendellAuthor Commented:
Yup definitely nearly there. Replication is now working from 2010 back to 2003 but unfortunately not the other way yet. I guess if we can get the messages delivered 2003 -> 2010 it will start working.
0
BikkelbinkCommented:
Ok, we´re getting somewhere now!
Do you see the new Routing Group connector in your Exchange 2003 System Manager?
When you open the RGC (ignore the warning) on the general page, do you see the server with the correct SMTP virtual server? If you have multiple SMTP virtual servers, you have to recreate only this connector. If needed recreate it with the 2003 System manager and choose the correct SMTP virtual server.
And you can check the mail frol troubleshooter on your EX 2010 server. These checks give you quite some usefull information...
0
Sam_RendellAuthor Commented:
I've checked the RGC and it has the correct servers listed.

I created a new RGC using SM2003 and gave it a cost of 1, I also raised the cost of the catch-all smart host connector to 2. Emails moved to the new queue and sat there.

The only thing I can think is that the 2010 box is refusing them for some reason. But as MS decided RGCs weren't important enough to be in the GUI I have no idea what could be causing the problem.

Any ideas?

0
Sam_RendellAuthor Commented:
Sorry, the message flow thingy only said that the 2003 box had an SMTP connector on it and to make sure the messages weren't sat in that. Which they aren't.
0
BikkelbinkCommented:
Did you configured a smart host in your SMTP virtual server?
If so, this problem can occure. Remove it from your SMTP virtual server which is connected to the Routing Group Connector.
0
BikkelbinkCommented:
I believe if there are External DNS servers configured on the SMTP virtual server is also doesn't work...
0
Sam_RendellAuthor Commented:
Slightly confused.

I have removed the SMTP connector completely. The only thing showing under Routing Groups is now RGC to the 2010 box.

The 2003 server has only two internal DNS servers set. It can resolve and ping the 2010 box and there are no firewalls in the way.

0
BikkelbinkCommented:
No...that's not right.
You need a SMTP connector.
You can configure into your SMTP connector if all mail will be sent to a smart host (when you use the SMTP server from your ISP) or you can configure External DNS servers (other than configured on your NIC) into the SMTP connector to bypass your internal DNS settings.
Recreate your SMTP connector and leave everything default. Create a RGC with this SMTP connector (if it does not automatically does for your existing RGC). After that, replication and mail flow should be going...
I'm heading home now. Hope you'll understand the above. I'll try to look this evening if you have anymore questions.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Sam_RendellAuthor Commented:
I see what you are saying now however when I try to recreate the SMTP connector it says I must enter a smart host.

I haven't asked it to use a bleeding smarthost!
0
Sam_RendellAuthor Commented:
Never mind I have sorted it. I had to specify the 2010 box as a smart host for the SMTP connector before it would let me add the RGC to it.

Messages have all been delivered now.

Replication is underway.

Thanks for all your help chap, much appreciated.

Sam.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.