MTU configuration on Windows 2000 Server

I have a problem concerning a third party trying to FTP to one of our servers. If they try and FTP a small amount of information it succeeds without any problems, but if they transfer kargers amounts of information the process stalls and eventually times out. After some investigation I believe that it is something to do with the packet size bing transmitted by the server as I have done a Wireshark capture that shows an ICMP packet is being set back from the router stating that Fragmentation is needed.

I have applied some registry changes on the receiving server which have disabled PMTU and I have also set the MTU on the interface to 1500. In addition to this I have been thinking about adding Black Hole Detection, but I am unsure as to whether I need this or not.

Could anyone advise what Black Hole detection actually does?
LVL 1
MartynLawsonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rick_O_ShayCommented:
The ICMP about fragmentation is saying that a packet with the do not fragment bit set is hitting a device in the network where the packet needs to be fragmented to continue. What ever application is setting the don't fragment should be changed to allow any networking devices to fragment as required.
0
MartynLawsonAuthor Commented:
The application that is trying to send the information is the ISS FTP site, but I have also tried Bulletproof FTP and Filezilla and they all have the same issue. Like I said above I have set the MTU on the interface to 1500 and I have disabled the PMTU, but alot of the sites mention Black Hole routers, but I am not sure of whether I need this setting to be active
0
Rick_O_ShayCommented:
You don't want to lock the MTU at 1500 as that is too big for something in the path. You would need to go smaller. Try somehting like 1420.

You can test for what is the max segment size being allowed by using the ping -f -l as documented in: http://support.microsoft.com/kb/159211

The Windows TCP is supposed to adjust its max segment size when it gets the ICMP back.
Black hole detection is used when a router doesn't send the ICMP to try to find the max size for the path and then adjust to it.  It is called a balck hole because it just drops the packet and doesn't tell anyone about it.

PMTU discovery is also used to help determine what is the max size that should be used.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MartynLawsonAuthor Commented:
I found that the MTU should be 1400 and it appears to work fine now.

Thanks for your help, it is greatly appreciated
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.