• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 605
  • Last Modified:

Offline Files for Laptops

We have set up a 2008 R2 Domain controller with roaming profiles and folder redirection.  The folders that are redirected are:  Desktop, Favorites, My Documents, and App Data.

At first, offline files were working on all the systems but that was causing issues.  So, I turned off all offline files and in the default domain policy.  Then I created a new GPO that turned the offline files back on and used security filtering to assign the GPO to one user that has a laptop.  I removed Authenticated Users for this CPO

When the user is on the network is files synchronize.  Everything is awesome.  All the desktop users are not synchronizing but their folder are redirected.

I will take the laptop off the network and shut it down and turn it on and all if his stuff is there ( this is at the office).   However, when he goes home a default profile is created and he can no longer access his data. When he comes back in the next morning everything syncs up and all is well.

Anybody has any idea as to why things don't work at his home?
  • 6
  • 5
  • 2
  • +2
1 Solution
vmwarun - ArunCommented:
Are you using Cached Credentials in your Domain ?
The reason why a new profile is created everytime when he logs in at home is the Laptop is unable to find the Domain Controller and creates a local profile to work with for the time being.
arunraja i am not certain your statement is accurate, if domain credentials are not cached and the machine is not connected to the domain then you will not be able to log on using the domain creds.
ne3 make sure the guy is trying to log on to the domain profile and do make sure that cached credentials are available.
vmwarun - ArunCommented:
mrkingsley, my first question is to the author about the setting.
The second statement is the explanation for not enabling Cached Credentials in the Domain.
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

My first thoughts are, you should never use the default domain policy for adding new policies into the domain, only use it to adjust settings that are already there, like password length and the like.
Alway create a new policy for folder redirection and offline files, it will make your life a whole lot easier:-).
Make sure your XP machine(s) has SP3 installed and you check MS Update> custom install> software, check under there for the latest Client Side Extensions. If you don't have these installed when using a 2008 R2 domain you will have trouble with group policies.
Try this first and let me know how it goes.
ne3Author Commented:
Thank you for your responses.

First, I did create  a GPO specifically for folder redirection.  This is in a create OU that all the users are in.  I did modify the Folder Redirection GPO to turn off offline files but it wasn't working.  So, just to test I modified the default GPO.  Not proud but it is working and didn't have time to troubleshoot and put it back.

Second, the laptop user was working fine for about a month with folder redirection and offline files.  Meaning offline files on by default by implementing Folder Redirection.  The laptop didn't have any problems until I:

1. Turned off offline files in the Default Domain GPO and the Folder Redirection GPO.
2. Create a new GPO to turn on offline files and used security filtering to make it apply to only the one user.  ( I also create a new OU called Laptops and a Global Security Group and added the user to the Group and have that group in the security filter).

Now, all other users are using Folder Redirection with offline files turned off and the lap top machine is using Folder Redirection with offline files turned on.  But, now he can't access his files when at home.

There is some little piece that I am missing somewhere.

Thank you for all of your repsonses
ne3Author Commented:

I lied.  yesterday offline flies was working for the laptop user.  But, now it is not.  which would explain why it doesn't work at his house.  

So, now the question is.. .why doesn't the GPO work for the one laptop user?
It appears when he goes home he is not logging into the same profile he is using at work, that would be why the offline files would not show up, how does that sound?
conchcrawl that is what i said previously
It almost sounds like the romaing profile is not staying on his local machine, that when he logs off it is being deleted and hence why the profile wouldn't be there when he went home. Make sure the user isn't loading under a temp profile.
Here is another thing I would do.
1. login to the workstation (ws) with the local administrator account.
2. go to documents and settings folder and copy the most current profile for the user that logs into this machine to a safe place. The date modified should tell you which one that is. Also remove the roaming profile from the server as well.
3. right click on my computer and click on properties then the advanced tab and then user profiles.
4. remove all users except the local administrator account.
5. go to control panel and local user accounts and remove all except local administrator.
6. reboot the computer, login to the domain with the users domain credentials
This will give you a clean install of the user profile for the domain without pulling any old crap (that is the technical term:-)) from the user profile. Trust me it is usually not worth it. You can then copy most data back over to the proper folders in the new user profile including the nk2 file.
@mrk, sorry, then i was just validating your earlier comments :-).
ne3Author Commented:
thank you for responding.  

However, I don't think the issue is with the raoming profile.  Everthing was working like it should on and off the LAN before turning off Offline Files.  It I put group policy back to where Offline file was enable for every use the laptop works as it should.

The problem is that I can not get Group Policy to turn on Offline flies for the laptop user and not for everyone else.  

Sorry for the confusion.
OK, then can you check this link out to make sure all these persmissions are set correctly?
Their are some other scenarios that could be causing this but lets try one step at a time:-).
ne3Author Commented:
Thank you to everyone who has tried to help me out.  I will post what the SOLUTION was on here for anybody else that runs across this issue.


As I mentioned before, this was a group policy issue. The main problem is that Offline Files are a computer setting in XP and NOT a user setting.  So, I had to create an OU for desktops and an OU for laptops.  Then I had to put the computers into the correct desktop or laptop OU.

Then, you create a GPO inside the OU with the desktops and laptops and NOT the OU for the users.  I used the following settings

Desktop Policy:

Allow or Disallow use of the Offline Files feature------Disabled
Prohibit user configuration of Offline Files------------Enabled
Remove 'Make Available Offline'-------------------------Enabled
Synchronize all offline files before logging off--------Disabled
Synchronize all offline files when logging on-----------Disabled
Synchronize offline files before suspend----------------Disabled

Laptop Policy:

Allow or Disallow use of the Offline Files feature----Enabled
Encrypt the Offline Files cache-----------------------Disabled
Non-default server disconnect actions-----------------Enabled
Prevent use of Offline Files folder-------------------Enabled
Reminder balloon frequency----------------------------Enabled
Reminder balloon lifetime-----------------------------Enabled
Subfolders always available offline-------------------Enabled
Synchronize all offline files before logging off------Enabled
Synchronize all offline files when logging on---------Enabled
Synchronize offline files before suspend--------------Disabled

I have not tested it but I read that with Vista you would be able to set a group policy based on the user for Offline files and not the Computer.  

Consequently, no matter what user logs into a laptop the Offline Files will be enabled.  And, any user that logs into a desktop machine will have Offline FIle disabled.
Did you ever try my previous comment
>>Make sure your XP machine(s) has SP3 installed and you check MS Update> custom install> software, check under there for the latest Client Side Extensions. If you don't have these installed when using a 2008 R2 domain you will have trouble with group policies.
ne3Author Commented:
I don't really mind that the question is deleted but I did give the solution for others to see.  But I mistyped my last comment

"I will post what the problem was on here for anybody else that runs across this issue. "  should have been "I will post what the SOLUTION was on here for anybody else that runs across this issue. "

Nobody came anywhere close to helping me with this. It took a lot of research on my own and I thought I would be good for others to see the solution.

Did you ever find a resolution to that addresses the issue that anyone that logs on to the laptop will have folder synchronization opposed to just the user(s) in a "laptop users" group / OU?

I have offline folders syncing the "my documents" folder, which is a redirected folder on the network.  But I have the issue where anyone that logs on the laptop will get files sync'd instead of just a specific list of users the resided in the laptop users group.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 6
  • 5
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now